Bug 1469179 - invoke checkpatch.pl with strict
invoke checkpatch.pl with strict
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: build (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Raghavendra Talur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-10 11:37 EDT by Raghavendra Talur
Modified: 2017-09-05 13:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.12.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-05 13:36:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra Talur 2017-07-10 11:37:58 EDT
Description of problem:
We seem to follow most of the coding guidelines which are checked in strict mode in checkpatch.pl. It would save a lot of time for new contributors and maintainers if these warnings are shown *before* sending the patch.
Comment 1 Worker Ant 2017-07-10 11:38:23 EDT
REVIEW: https://review.gluster.org/17737 (rfc.sh: make alignment check compulsory) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 2 Worker Ant 2017-07-18 07:22:25 EDT
COMMIT: https://review.gluster.org/17737 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 43d55c5afb1a9f731d806f7893923ac999b9ef6c
Author: Raghavendra Talur <rtalur@redhat.com>
Date:   Mon Jul 10 20:43:39 2017 +0530

    rfc.sh: make alignment check compulsory
    
    Earlier, it was not reported if a function call had arguments on next
    line and the args were not aligned to opening bracket. With this change,
    it is a check that is displayed in output.
    
    I have not analyzed what all --strict brings in. If it is found to be
    more restrictive than required, we may choose to promote this *one* CHK
    to WARN and stop using --strict.
    
    Sample:
    
    CHECK: Alignment should match open parenthesis
    +                ret = gf_asprintf (&footer,
    +                                " [%s]", strerror(errnum));
    
    total: 0 warnings, 1 checks, 8 lines checked
    
    Change-Id: I48834087efcae872b69746ba962b0bb1c130b5cd
    BUG: 1469179
    Signed-off-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-on: https://review.gluster.org/17737
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Prashanth Pai <ppai@redhat.com>
    Reviewed-by: ankitraj
    Reviewed-by: Jeff Darcy <jeff@pl.atyp.us>
    Reviewed-by: Sonal Arora <sarora@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 3 Shyamsundar 2017-09-05 13:36:59 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.