Bug 1469223 - power base image includes unnecessary packages
power base image includes unnecessary packages
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rhel-server-ppc64le-docker (Show other bugs)
7.4
ppc64le Linux
high Severity high
: rc
: ---
Assigned To: Frantisek Kluknavsky
Martin Jenner
: Extras
Depends On:
Blocks: 1405448
  Show dependency treegraph
 
Reported: 2017-07-10 12:44 EDT by CAI Qian
Modified: 2017-08-05 10:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 09:20:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to kickstart file to avoid extra packages (827 bytes, patch)
2017-07-11 09:43 EDT, Josh Boyer
no flags Details | Diff

  None (edit)
Description CAI Qian 2017-07-10 12:44:31 EDT
Description of problem:
For ppc64le, I am not sure we need lvm2, lvm2-libs, libaio, device-mapper-event,
device-mapper-event-libs, and device-mapper-persistent-data in the base image where we don't include them in the x86_64 version.
I can remove them all manually without dependency issues.

Version-Release number of selected component (if applicable):
7.4 rc

How reproducible:
always
Comment 1 Josh Boyer 2017-07-11 09:38:42 EDT
I looked at this more closely this morning.  The extra packages are entirely because we are using "autopart" for partitioning in the kickstart file.  I was able to do a scratch build of the base image using "autopart --nolvm" in the kickstart file and it removes the packages listed.  You can see this here:

[root@ibm-p8-kvm-05-guest-09 ~]# docker pull brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/rhel7-ppc64le:none-20170711082034
Trying to pull repository brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/rhel7-ppc64le ... 
none-20170711082034: Pulling from brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/rhel7-ppc64le
409c608d670b: Pull complete 
2de41c99ce1d: Pull complete 
Digest: sha256:6211c0ee991fa30dddf0edf74e2bb013375d688fc1f6c69cfc65c4fc0e68c975
[root@ibm-p8-kvm-05-guest-09 ~]# docker run -it 6c4a4d1d12d9 /bin/bash
[root@e619fa54e8d1 /]# rpm -qa | grep lvm
[root@e619fa54e8d1 /]# rpm -qa | grep device-mapper
device-mapper-1.02.140-8.el7.ppc64le
device-mapper-libs-1.02.140-8.el7.ppc64le
[root@e619fa54e8d1 /]# rpm -qa | grep libaio       
[root@e619fa54e8d1 /]# 

The full difference between this scratch build and the latest x86_64 base image is now this:

[jwboyer@x1 ~]$ diff -Nup x86.list ppc64le.list 
--- x86.list	2017-07-11 09:37:43.695278510 -0400
+++ ppc64le.list	2017-07-11 09:37:29.880351119 -0400
@@ -20,7 +20,6 @@ dbus-python-1.1.1-9.el7
 device-mapper-1.02.140-8.el7
 device-mapper-libs-1.02.140-8.el7
 diffutils-3.3-4.el7
-dmidecode-3.0-5.el7
 dracut-033-502.el7
 elfutils-default-yama-scope-0.168-8.el7.noarch
 elfutils-libelf-0.168-8.el7
@@ -119,7 +118,6 @@ python-rhsm-1.19.9-1.el7
 python-rhsm-certificates-1.19.9-1.el7
 python-urlgrabber-3.10-8.el7.noarch
 pyxattr-0.5.1-5.el7
-qemu-guest-agent-2.8.0-2.el7
 qrencode-libs-3.4.1-3.el7
 readline-6.2-10.el7
 redhat-release-server-7.4-18.el7
[jwboyer@x1 ~]$ 

Both packages missing in the ppc64le container are x86_64 only for now, so that is expected.
Comment 2 Josh Boyer 2017-07-11 09:43 EDT
Created attachment 1296260 [details]
Patch to kickstart file to avoid extra packages

This is the entirety of the patch.
Comment 7 errata-xmlrpc 2017-08-01 09:20:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2374

Note You need to log in before you can comment on or make changes to this bug.