Bug 1469266 - Menu entries missing from Horizon if cinder v1 endpoint is deleted.
Menu entries missing from Horizon if cinder v1 endpoint is deleted.
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
11.0 (Ocata)
x86_64 Linux
high Severity high
: z2
: 11.0 (Ocata)
Assigned To: Radomir Dopieralski
Ido Ovadia
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-10 14:56 EDT by Siggy Sigwald
Modified: 2017-09-13 17:37 EDT (History)
5 users (show)

See Also:
Fixed In Version: python-django-horizon-11.0.3-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-13 17:37:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1670789 None None None 2017-07-10 14:56 EDT

  None (edit)
Description Siggy Sigwald 2017-07-10 14:56:45 EDT
Description of problem:
In the case where there is no cinder v1 endpoint created (or deleted - use openstack service delete cinder to reproduce) certain volume related menu entries are not displayed - Create volume from instance snapshot and create instance from volume - see attachments.
How reproducible:
Every time v1 endpoint is deleted
More information to be added shortly.
Comment 2 Radomir Dopieralski 2017-08-24 07:06:16 EDT
This has been fixed upstream in Pike and back-ported to Ocata. It will be included in the next release for Ocata.
Comment 5 Ido Ovadia 2017-09-04 07:52:56 EDT
Verified
========
python-django-horizon-11.0.3-3.el7ost.noarch
Comment 7 errata-xmlrpc 2017-09-13 17:37:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2717

Note You need to log in before you can comment on or make changes to this bug.