This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1469339 - [virt-v2v] Inspection Could Not Detect Source Guest (CentOS OVA from VMware)
[virt-v2v] Inspection Could Not Detect Source Guest (CentOS OVA from VMware)
Status: CLOSED DUPLICATE of bug 1186935
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-10 22:33 EDT by Zach Seils
Modified: 2017-07-11 02:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-11 02:42:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-v2v output with -v -x (126.51 KB, text/plain)
2017-07-10 22:33 EDT, Zach Seils
no flags Details

  None (edit)
Description Zach Seils 2017-07-10 22:33:17 EDT
Created attachment 1296028 [details]
virt-v2v output with -v -x

Description of problem:

While trying to convert an OVA exported from VMware vSphere to libvirt using virt-v2v, I get the following error:

virt-v2v: error: inspection could not detect the source guest (or physical 
machine).

Version-Release number of selected component (if applicable):

Base OS: 16.04.2 LTS (Xenial Xerus)
Source VM OS: CentOS 7
libguestfs: 1.32.2 (patched with https://github.com/libguestfs/libguestfs/commit/fd60be95091a1923e108f72caf251f5549eeccd0)


How reproducible: 100%


Steps to Reproduce:
1. Export CentOS using VMware ovftool
2. Execute virt-v2v command:

sudo virt-v2v -v -i ova fso-app-p01.ova -o libvirt -os projects -of qcow2

Actual results: See attached log.


Expected results: No failures; new domain created from source OVA.


Additional info:
Comment 1 Pino Toscano 2017-07-11 02:42:25 EDT
This happens because that version of libguestfs does not identifies correctly a separate /usr partition.

This was reported already as bug 1186935, and fixed in libguestfs >= 1.35.15.

*** This bug has been marked as a duplicate of bug 1186935 ***

Note You need to log in before you can comment on or make changes to this bug.