Bug 1469366 - Port status should reflect the actual status of the port
Port status should reflect the actual status of the port
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-odl (Show other bugs)
11.0 (Ocata)
Unspecified Unspecified
medium Severity medium
: beta
: 12.0 (Pike)
Assigned To: Josh Hershberg
Itzik Brown
: Triaged
Depends On: 1414298
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 02:37 EDT by Itzik Brown
Modified: 2017-12-13 16:40 EST (History)
3 users (show)

See Also:
Fixed In Version: python-networking-odl-11.0.0-0.20170707060026.5ccb48f.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-13 16:40:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 465462 None None None 2017-07-11 03:49 EDT
OpenStack gerrit 465463 None None None 2017-07-11 03:49 EDT

  None (edit)
Description Itzik Brown 2017-07-11 02:37:39 EDT
Description of problem:
The port status is ACTIVE even when it's attached to an instance and the instance is not up.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a port 
2. Launch an instance with the above port attached
3. Watch that the port status is active even that the instance is not running.

Actual results:


Expected results:


Additional info:
Comment 1 Mike Kolesnik 2017-07-11 02:45:49 EDT
I would say that after step 1 you can already see the port is in status ACTIVE even though its not really provisioned yet. The actual problem is that it's immediately set to active instead of when it's provisioned on the network as is in vanilla Neutron.

Also please notice it's not expected of the port to change status after it changes to ACTIVE (per current Neutron behavior).
Comment 4 Itzik Brown 2017-08-08 04:27:53 EDT
Checked that that the instance is not in 'active running' state before the port status is active.
Checked with python-networking-odl-11.0.0-0.20170721155128.a047729.el7ost.noarch
Comment 7 errata-xmlrpc 2017-12-13 16:40:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Note You need to log in before you can comment on or make changes to this bug.