Bug 1469440 - Request for including an upstream fix(466514/) for emc vnx volume driver
Request for including an upstream fix(466514/) for emc vnx volume driver
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
11.0 (Ocata)
Unspecified Unspecified
medium Severity medium
: z2
: 11.0 (Ocata)
Assigned To: Eric Harney
Avi Avraham
: OtherQA, Triaged, ZStream
Depends On: 1465119
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 05:33 EDT by Peter Wang
Modified: 2017-09-13 17:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: openstack-cinder-10.0.3-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-13 17:49:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Wang 2017-07-11 05:33:31 EDT
Description of problem:

VNX driver should use the `state_path` instead of home of current
user, or we may meet permission error when creating folder for storing
data.

Version-Release number of selected component (if applicable):
RedHat Openstack 11(Ocata)

How reproducible:


Steps to Reproduce:
1. configure VNX driver as cinder backend
2. restart cinder volume
3.

Actual results:

Driver failed to start as permission denied

Expected results:
the driver can start up normally.

Additional info:

This is already fixed and backported to ocata

https://review.openstack.org/#/c/466514/
Comment 1 Eric Harney 2017-07-11 09:37:34 EDT
This will be included in the 10.0.3 openstack-cinder build.
Comment 2 Lily Jing 2017-07-26 03:40:44 EDT
(In reply to Eric Harney from comment #1)
> This will be included in the 10.0.3 openstack-cinder build.

Eric,

Any ETA of the build?
Comment 6 errata-xmlrpc 2017-09-13 17:49:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2715

Note You need to log in before you can comment on or make changes to this bug.