Bug 1469460 - [cisco_ucsm] ucsm_host_list parameter is incorrect because code is not "composable role ready" [NEEDINFO]
[cisco_ucsm] ucsm_host_list parameter is incorrect because code is not "compo...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
10.0 (Newton)
Unspecified Unspecified
high Severity high
: z5
: 10.0 (Newton)
Assigned To: Joe Donohue
Toni Freger
: OtherQA, Triaged, ZStream
Depends On:
Blocks: 1321623 1335596
  Show dependency treegraph
 
Reported: 2017-07-11 06:13 EDT by Sid Ahmed Sadouni
Modified: 2017-09-28 12:35 EDT (History)
14 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-5.3.0-6.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-28 12:35:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
atelang: needinfo? (jdonohue)


Attachments (Terms of Use)

  None (edit)
Description Sid Ahmed Sadouni 2017-07-11 06:13:17 EDT
We are using the env file environments/neutron-ml2-cisco-nexus-ucsm.yaml for cisco_ucsm mechanism driver and composable role for our needs in NFV.

environments/neutron-ml2-cisco-nexus-ucsm.yaml  calls puppet/extraconfig/all_nodes/neutron-ml2-cisco-nexus-ucsm.yaml which is not "composable role ready"

We are in a case for NFV where we need different type of compute role.

For the 'Compute like' role we configure, the parameter ucsm_host_list is not generated.
This is a problem when we want to spawn a VM with an SR-IOV interface on a compute. 

Thanks,
Comment 1 Sandhya Dasu 2017-07-12 16:05:12 EDT
I would like TripleO experts to chime in on this issue. Obviously, the final solution would be for config for Cisco mech drivers to be compossible role compatible. Since, this issue has to be fixed in OSP10, a different solution needs to be found in the meantime.

I am currently looking at:
tripleo-heat-templates/puppet/extraconfig/all_nodes/neutron-ml2-cisco-nexus-ucsm.yaml

I think the reason, compute hosts with different compute roles are being ignored is because of this:
  CollectMacDeploymentsCompute:
    type: OS::Heat::SoftwareDeployments
    properties:
      name: CollectMacDeploymentsCompute
      servers:  {get_param: [servers, Compute]}  <-----
      config: {get_resource: CollectMacConfig}
      actions: ['CREATE'] # Only do this on CREATE

Looking for suggestions from the Triple experts. Can the "Compute" string be a regular expression? Or, should be create a block like this for every compute role (brute force, I know)?
Comment 2 Sandhya Dasu 2017-07-17 15:12:46 EDT
Opened a new triple bug: https://bugs.launchpad.net/tripleo/+bug/1704853
describing the issue as I see it.
Comment 4 Sandhya Dasu 2017-07-27 09:55:44 EDT
Fix has been back ported to stable/newton via:https://review.openstack.org/#/c/487164/.
This needs to make its way into OSP10.
Comment 10 errata-xmlrpc 2017-09-28 12:35:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2825

Note You need to log in before you can comment on or make changes to this bug.