Bug 1469487 - sys_xxx() functions should guard against bad return values from fs
sys_xxx() functions should guard against bad return values from fs
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
mainline
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 07:30 EDT by Pranith Kumar K
Modified: 2018-03-15 07:17 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-4.0.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-15 07:17:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2017-07-11 07:30:52 EDT
Description of problem:
    Problem:
    FS sometimes doesn't give the expected return values. We need our common
    functions to guard against this.
    Example BUG: https://bugzilla.redhat.com/show_bug.cgi?id=864401
    
    Fix:
    When the return value is not as per specification, change the return value
    to -1 and errno to EIO


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Worker Ant 2017-07-11 07:32:04 EDT
REVIEW: https://review.gluster.org/17746 (libglusterfs: Handle FS errors gracefully) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Worker Ant 2017-07-11 09:41:47 EDT
REVIEW: https://review.gluster.org/17746 (libglusterfs: Handle FS errors gracefully) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 3 Worker Ant 2017-07-11 10:12:47 EDT
REVIEW: https://review.gluster.org/17746 (libglusterfs: Handle FS errors gracefully) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 4 Worker Ant 2017-07-14 00:47:25 EDT
REVIEW: https://review.gluster.org/17746 (libglusterfs: Handle FS errors gracefully) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 5 Worker Ant 2017-07-14 13:40:50 EDT
REVIEW: https://review.gluster.org/17746 (libglusterfs: Handle FS errors gracefully) posted (#5) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 6 Worker Ant 2017-07-14 20:59:50 EDT
REVIEW: https://review.gluster.org/17746 (libglusterfs: Handle FS errors gracefully) posted (#6) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 7 Worker Ant 2017-07-14 21:48:22 EDT
REVIEW: https://review.gluster.org/17746 (libglusterfs: Handle FS errors gracefully) posted (#7) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 8 Worker Ant 2017-07-15 06:11:10 EDT
REVIEW: https://review.gluster.org/17746 (libglusterfs: Handle FS errors gracefully) posted (#8) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 9 Worker Ant 2017-07-15 10:43:40 EDT
REVIEW: https://review.gluster.org/17746 (libglusterfs: Handle FS errors gracefully) posted (#9) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 10 Worker Ant 2017-07-15 11:58:48 EDT
REVIEW: https://review.gluster.org/17746 (libglusterfs: Handle FS errors gracefully) posted (#10) for review on master by Xavier Hernandez (xhernandez@datalab.es)
Comment 11 Worker Ant 2017-07-18 03:00:15 EDT
REVIEW: https://review.gluster.org/17746 (libglusterfs: Handle FS errors gracefully) posted (#11) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 12 Worker Ant 2017-08-22 04:29:47 EDT
REVIEW: https://review.gluster.org/18083 (libglusterfs: Handle FS errors gracefully) posted (#1) for review on experimental by Amar Tumballi (amarts@redhat.com)
Comment 13 Worker Ant 2017-08-22 05:32:29 EDT
REVIEW: https://review.gluster.org/18083 (libglusterfs: Handle FS errors gracefully) posted (#2) for review on experimental by Amar Tumballi (amarts@redhat.com)
Comment 14 Worker Ant 2017-08-22 08:26:06 EDT
REVIEW: https://review.gluster.org/18083 (libglusterfs: Handle FS errors gracefully) posted (#3) for review on experimental by Amar Tumballi (amarts@redhat.com)
Comment 15 Worker Ant 2017-08-22 21:22:29 EDT
COMMIT: https://review.gluster.org/18083 committed in experimental by Amar Tumballi (amarts@redhat.com) 
------
commit dbd0d50eed0d89d7a42292f96cf5ae192e107a07
Author: Amar Tumballi <amarts@redhat.com>
Date:   Fri Aug 18 16:05:32 2017 +0530

    libglusterfs: Handle FS errors gracefully
    
    Problem:
    FS sometimes doesn't give the expected return values. We need our common
    functions to guard against this.
    Example BUG: https://bugzilla.redhat.com/show_bug.cgi?id=864401
    
    Fix:
    When the return value is not as per specification, change the return value
    to -1 and errno to EIO
    
    BUG: 1469487
    Change-Id: I14739ab2e5ae225b1a91438b87f8928af56f2934
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: https://review.gluster.org/18083
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Tested-by: Amar Tumballi <amarts@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
Comment 16 Worker Ant 2017-10-30 04:20:54 EDT
REVIEW: https://review.gluster.org/17746 (libglusterfs: Handle FS errors gracefully) posted (#12) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 17 Worker Ant 2017-11-22 05:08:11 EST
COMMIT: https://review.gluster.org/17746 committed in master by \"Pranith Kumar Karampuri\" <pkarampu@redhat.com> with a commit message- libglusterfs: Handle FS errors gracefully

Problem:
FS sometimes doesn't give the expected return values. We need our common
functions to guard against this.
Example BUG: https://bugzilla.redhat.com/show_bug.cgi?id=864401

Fix:
When the return value is not as per specification, change the return value
to -1 and errno to EIO

BUG: 1469487
Change-Id: I14739ab2e5ae225b1a91438b87f8928af56f2934
Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
Comment 18 Worker Ant 2017-12-06 07:33:57 EST
REVIEW: https://review.gluster.org/18951 (libglusterfs: Handle FS errors gracefully) posted (#1) for review on experimental by Kotresh HR
Comment 19 Worker Ant 2017-12-06 10:10:14 EST
COMMIT: https://review.gluster.org/18951 committed in experimental by \"Kotresh HR\" <khiremat@redhat.com> with a commit message- libglusterfs: Handle FS errors gracefully

Problem:
FS sometimes doesn't give the expected return values. We need our common
functions to guard against this.
Example BUG: https://bugzilla.redhat.com/show_bug.cgi?id=864401

Fix:
When the return value is not as per specification, change the return value
to -1 and errno to EIO

BUG: 1469487
Change-Id: Id23fdbcf7aefc4f779e76db824cb4c74d580de1f
Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
Comment 20 Shyamsundar 2018-03-15 07:17:12 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.0.0, please open a new bug report.

glusterfs-4.0.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-March/000092.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.