Bug 1469548 - GDBus.Error when trying to run Caja
GDBus.Error when trying to run Caja
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: caja (Show other bugs)
25
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Wolfgang Ulbrich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 09:29 EDT by bokkenka
Modified: 2017-07-27 23:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-12 01:24:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bokkenka 2017-07-11 09:29:42 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36
Build Identifier: 

After upgrading to caja 1.18.3-1, it will not run anymore.  Starting from a menu entry, nothing happens.  Starting from a command line, I get the error...

Could not register the application: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface 'org.gtk.Actions' on object at path /org/mate/Caja

I've had to downgrade to the previous version to get it to work.

Reproducible: Always

Steps to Reproduce:
1. Start Caja
Actual Results:  
From a menu entry, nothing happens.  From a command line, the error above is displayed.

Expected Results:  
Open the Caja filemanager.

Could not register the application: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface 'org.gtk.Actions' on object at path /org/mate/Caja
Comment 1 Wolfgang Ulbrich 2017-07-11 10:30:30 EDT
weird, i can't confirm that.
caja 1.18.3-1 runs fine here in several f25 installations.
Sounds like a upgrade issue.
Did you restart session/system?
Version of previous package please?
And please post the result of those commands.
rpm -qa libmate*
rpm -qa mate*
rpm -qa caja*
Comment 2 bokkenka 2017-07-11 11:19:10 EDT
I had originally logged out and back in, and rebooted the laptop, when it first upgraded on June 26 and didn't work.  I did neither this morning when I re-upgraded to get the error again to file the bug report.

It must have seen that I filed the bug report, because I just retried the upgrade and it's now working, without restarting either the session or system.  It continues to work after restarting both.  Like a car not making the weird noise for the mechanic.

I don't know the version it upgraded from to 1.18.3-1.  The dnf downgrade took caja, caja-extensions, and caja-schemas back to 1.16.1-1.

Here's the rpm queries (with caja 1.18.3-1 installed) in case you still want them...

libmateweather-data-1.18.1-1.fc25.noarch
libmatemixer-1.18.0-1.fc25.x86_64
libmateweather-1.18.1-1.fc25.x86_64
libmatekbd-1.18.2-1.fc25.x86_64


mate-search-tool-1.18.2-1.fc25.x86_64
mate-panel-1.18.3-1.fc25.x86_64
mate-session-manager-1.18.0-1.fc25.x86_64
mate-dictionary-1.18.2-1.fc25.x86_64
mate-polkit-1.18.1-1.fc25.x86_64
mate-backgrounds-1.18.0-1.fc25.noarch
mate-screenshot-1.18.2-1.fc25.x86_64
mate-menus-1.18.0-1.fc25.x86_64
mate-notification-daemon-1.18.0-1.fc25.x86_64
mate-screensaver-1.18.1-1.fc25.x86_64
mate-themes-3.22.12-1.fc25.noarch
mate-utils-common-1.18.2-1.fc25.noarch
mate-settings-daemon-1.18.1-1.fc25.x86_64
mate-media-1.18.1-1.fc25.x86_64
mate-disk-usage-analyzer-1.18.2-1.fc25.x86_64
mate-power-manager-1.18.0-1.fc25.x86_64
mate-icon-theme-1.18.2-1.fc25.noarch
mate-system-monitor-1.18.0-1.fc25.x86_64
mate-system-log-1.18.2-1.fc25.x86_64
mate-user-guide-1.18.0-1.fc25.noarch
mate-calc-1.18.0-1.fc25.x86_64
mate-panel-libs-1.18.3-1.fc25.x86_64
mate-control-center-filesystem-1.18.2-1.fc25.x86_64
mate-control-center-1.18.2-1.fc25.x86_64
mate-terminal-1.18.1-1.fc25.x86_64
mate-desktop-1.18.0-2.fc25.x86_64
mate-menus-libs-1.18.0-1.fc25.x86_64
mate-menus-preferences-category-menu-1.18.0-1.fc25.x86_64
mate-desktop-libs-1.18.0-2.fc25.x86_64
mate-applets-1.18.1-1.fc25.x86_64


caja-wallpaper-1.18.1-1.fc25.x86_64
caja-schemas-1.18.3-1.fc25.x86_64
caja-sendto-1.18.1-1.fc25.x86_64
caja-extensions-common-1.18.1-1.fc25.noarch
caja-open-terminal-1.18.1-1.fc25.x86_64
caja-extensions-1.18.3-1.fc25.x86_64
caja-1.18.3-1.fc25.x86_64
caja-image-converter-1.18.1-1.fc25.x86_64


Thanks for fixing it.  :)  I'm the go-to "computer guy" in the office and do quite a few fixes by laying-on hands.
Comment 3 Wolfgang Ulbrich 2017-07-12 01:24:07 EDT
Ok, i am glad to hear that it works now. :-)
Comment 4 Ben Parees 2017-07-27 23:49:06 EDT
I also had this issue, in my case it was solved after a full update and a reboot (the update alone was not sufficient).

Note You need to log in before you can comment on or make changes to this bug.