Bug 1469563 - required bind version doesn't have the dyndb interface
required bind version doesn't have the dyndb interface
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: bind-dyndb-ldap (Show other bugs)
All Unspecified
high Severity urgent
: rc
: ---
Assigned To: Petr Vobornik
: Regression, ZStream
Depends On:
Blocks: 1469984
  Show dependency treegraph
Reported: 2017-07-11 09:52 EDT by Tomas Krizek
Modified: 2018-02-14 17:50 EST (History)
5 users (show)

See Also:
Fixed In Version: bind-dyndb-ldap-11.1-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1469984 (view as bug list)
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tomas Krizek 2017-07-11 09:52:05 EDT
Description of problem:
bind-dyndb-ldap requires dyndb patches that are present in 7.4 in bind since version 9.9.4-44. However, bind version 9.9.4-50 was released to 7.3.z to prevent a security regression (https://bugzilla.redhat.com/show_bug.cgi?id=1469480#c4 ) and this version doesn't contain the patches required by bind-dyndb-ldap, yet it meets the required version.

As a result, bind-dyndb-ldap doesn't pull in new version of bind, which renders the component unusable until bind is updated manually.

Version-Release number of selected component (if applicable):

How reproducible:

Additional info:
This also breaks ipa server upgrade or installation: https://bugzilla.redhat.com/show_bug.cgi?id=1469480

Note You need to log in before you can comment on or make changes to this bug.