Bug 1469566 - Broken link to remote API docs
Broken link to remote API docs
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Documentation (Show other bugs)
JON 3.0.0
Unspecified Unspecified
medium Severity medium
: post-GA
: ---
Assigned To: Tyler Kelly
Mike Foley
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 09:53 EDT by Larry O'Leary
Modified: 2017-08-25 01:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-25 01:12:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry O'Leary 2017-07-11 09:53:52 EDT
Document URL: 

https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_Operations_Network/3.0/html/Running_JON_Command-Line_Scripts/about-cli.html#java-reading

Section Number and Name: 
2.2. MORE JAVA RESOURCES

Describe the issue: 
The link http://docs.redhat.com/docs/en-US/JBoss_Operations_Network/3.0/html/API_Guides/index.html results in a 404.

Suggestions for improvement:
I am not sure where this document actually lives. Additionally, this URL seems to be referenced in other places as well. For example, I see it in the second paragraph of section 2. USING THE JBOSS ON CLI TO SCRIPT TASKS

The document that it should reference should be the JBoss ON 3.0 API Guide... I am not certain if this should be the actual Remote API JavaDoc or if this should be a guide that contained the JavaDoc link for the Remote API JavaDoc and Domain API JavaDoc.
Comment 2 Tyler Kelly 2017-07-11 22:08:48 EDT
This link refers to the doc when it was published under JON not RHJON, it's possible that the writers at the time had to change the title and url to not conflict with the older names.

The versions I have ready for publish also have these broken links. I will try to fix them up before I publish.
Comment 3 Tyler Kelly 2017-07-12 04:00:15 EDT
So far, I have fixed all the internal links in the 3.0 docs except for the API doc you have mentioned (there are about 13 of them throughout the docs). 

The API doc was published, and we still publish current versions of the API.
After re-checking the svn repo (https://svn.devel.redhat.com/repos/ecs/JON/) where the docs were previously and in brew (https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=300351) I still can't find a copy.

However, the 3.1 API doc has been recovered and lists changes from 2.4 to 3.0, 3.0 to 3.01 and 3.01 to 3.1.

https://brewweb.engineering.redhat.com/brew/packageinfo?packageID=44277

I could try re-add this API doc to 3.1 docs and change these links to point to it?
Comment 4 Larry O'Leary 2017-07-13 09:17:55 EDT
That will work Tyler.
Comment 5 Tyler Kelly 2017-07-13 21:19:22 EDT
Git Commits:
https://gitlab.cee.redhat.com/tkelly/jon_pre33/commit/09a3cf94dba5e35077d33bab5a8a78331f0132a7
https://gitlab.cee.redhat.com/tkelly/jon_pre33/commit/41b649c27791df4d868ca91f3d7a51252f2a9d2a

Git Merge:
https://gitlab.cee.redhat.com/red-hat-jboss-operations-network-documentation/jon_pre33/merge_requests/57

Pantheon Preview:
All 3.0 docs - search for "https://access.redhat.com/documentation/en-US" to find all 40+ changes, links can be provided if required.

Recommend QA review commits (above) rather than previews due to the volume of small changes.
Comment 10 Tyler Kelly 2017-08-25 01:12:07 EDT
Updated content now live on the customer portal:
Change regarding comment 6:
https://access.redhat.com/documentation/en-us/red_hat_jboss_operations_network/3.0/html-single/running_jon_command-line_scripts/#java-reading
Other changes are spread across the version 3.0 documentation, found here:
https://access.redhat.com/documentation/en/red-hat-jboss-operations-network/?version=3.0

Note You need to log in before you can comment on or make changes to this bug.