Bug 1469574 - [Docs][RFE][Director] Ability to enable/disable debug mode per openstack service
[Docs][RFE][Director] Ability to enable/disable debug mode per openstack service
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Dan Macpherson
Charelle Collett
:
: 1515168 (view as bug list)
Depends On: 1216988
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 10:05 EDT by Dan Macpherson
Modified: 2017-12-18 23:20 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-18 23:20:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Macpherson 2017-07-11 10:05:44 EDT
== DECRIPTION ==
We should have ability to move openstack service to debug mode and back to non debug after installation 
This requires 
1. edit service conf file
2. restart service
in HA mode we should do it to all controllers , same for compute 

== DOCS IMPACT ==
Requires documentation in Advanced Overcloud Guide on how to enable Debug mode. Also the Overclud Parameters guide needs to be refreshd to include these parameters
Comment 1 Dan Macpherson 2017-11-20 19:56:19 EST
*** Bug 1515168 has been marked as a duplicate of this bug. ***
Comment 5 Dan Macpherson 2017-11-22 20:42:32 EST
Alex, would you be able to take a look at the content items in comment #3 and let me know if I've missed anything?
Comment 6 Charelle Collett 2017-11-29 09:37:02 EST
Just checking `DEBUG` level logging and the `Debug` parameter are capitalised differently?  If that's correct then it looks good to me. :)
Comment 7 Gurenko Alex 2017-11-29 11:17:05 EST
(In reply to Charelle Collett from comment #6)
> Just checking `DEBUG` level logging and the `Debug` parameter are
> capitalised differently?  If that's correct then it looks good to me. :)

Yes, that's actually correct DEBUG is how it appears in logs, Debug or <Service>Debug is how you use it.

Everything looks good, except I'm actually not sure about this one "All per-service debug modes are enabled by default except for the OpenStack Dashboard (horizon)."
Comment 8 Dan Macpherson 2017-11-29 20:20:37 EST
Alex, you're right. It didn't seem right to me. I think I got mixed up when I saw the HorizonDebug was the only one that explicitly set the default to False. On further investigation, they're all false by default (via the Puppet params).

Will remove this line from the doc.
Comment 10 Dan Macpherson 2017-11-29 20:37:45 EST
Fix implemented.

If there's nothing else, I'll switch this BZ to VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.