Bug 1469600 - Import of key(s) didn't help, wrong key(s)?
Import of key(s) didn't help, wrong key(s)?
Status: CLOSED DUPLICATE of bug 1456079
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 10:25 EDT by Richard W.M. Jones
Modified: 2017-07-22 16:55 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-22 16:55:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2017-07-11 10:25:04 EDT
Description of problem:

From an Fedora 26 (x86_64) machine, I tried upgrading packages
to Rawhide, but ...

Last metadata expiration check: 0:00:02 ago on Tue Jul 11 10:15:36 2017.
Package bash-4.4.12-6.fc26.x86_64 is already installed, skipping.
Package dnf-2.5.1-1.fc26.noarch is already installed, skipping.
Package dnf-plugins-core-2.1.2-2.fc26.noarch is already installed, skipping.
Package sudo-1.8.20p2-1.fc26.x86_64 is already installed, skipping.
Dependencies resolved.
================================================================================
 Package                        Arch   Version                    Repository
                                                                           Size
================================================================================
Installing:
 emacs                          x86_64 1:25.2-2.fc27              rawhide 3.1 M
 mlocate                        x86_64 0.26-16.fc26               rawhide 117 k
 net-tools                      x86_64 2.0-0.42.20160912git.fc26  rawhide 311 k
 nfs-utils                      x86_64 1:2.1.1-5.rc4.fc27         rawhide 409 k
 ntp                            x86_64 4.2.8p10-1.fc27            rawhide 672 k
 telnet                         x86_64 1:0.17-69.fc27             rawhide  68 k
Upgrading:
 emacs-filesystem               noarch 1:25.2-2.fc27              rawhide  66 k
Installing dependencies:
 GConf2                         x86_64 3.2.6-17.fc26              rawhide 1.0 M
 ImageMagick-libs               x86_64 6.9.3.0-7.fc27             rawhide 2.2 M
 ModemManager-glib              x86_64 1.6.4-2.fc26               rawhide 234 k
 OpenEXR-libs                   x86_64 2.2.0-6.fc26               rawhide 628 k
 adwaita-cursor-theme           noarch 3.24.0-2.fc27              rawhide 645 k
 adwaita-icon-theme             noarch 3.24.0-2.fc27              rawhide  12 M
 alsa-lib                       x86_64 1.1.4.1-1.fc27             rawhide 421 k
 at-spi2-atk                    x86_64 2.25.3-1.fc27              rawhide  85 k
 at-spi2-core                   x86_64 2.25.4-1.fc27              rawhide 164 k
 atk                            x86_64 2.25.2-1.fc27              rawhide 268 k
 autogen-libopts                x86_64 5.18.12-3.fc27             rawhide  72 k
 avahi-glib                     x86_64 0.6.32-7.fc26              rawhide  13 k
 avahi-libs                     x86_64 0.6.32-7.fc26              rawhide  59 k
 cairo                          x86_64 1.14.10-1.fc27             rawhide 722 k
 cairo-gobject                  x86_64 1.14.10-1.fc27             rawhide  30 k
 cdparanoia-libs                x86_64 10.2-22.fc26               rawhide  57 k
 colord-libs                    x86_64 1.3.5-1.fc26               rawhide 200 k
 cups-libs                      x86_64 1:2.2.4-1.fc27             rawhide 420 k
 dejavu-fonts-common            noarch 2.35-4.fc26                rawhide  72 k
 dejavu-sans-mono-fonts         noarch 2.35-4.fc26                rawhide 445 k
 desktop-file-utils             x86_64 0.23-3.fc26                rawhide  75 k
 emacs-common                   x86_64 1:25.2-2.fc27              rawhide  38 M
 enchant                        x86_64 1:1.6.0-16.fc26            rawhide  58 k
 fftw-libs-double               x86_64 3.3.5-4.fc26               rawhide 980 k
 fontconfig                     x86_64 2.12.4-1.fc27              rawhide 247 k
 fontpackages-filesystem        noarch 1.44-18.fc26               rawhide  14 k
 gdk-pixbuf2                    x86_64 2.36.6-1.fc27              rawhide 459 k
 gdk-pixbuf2-modules            x86_64 2.36.6-1.fc27              rawhide 101 k
 geoclue2                       x86_64 2.4.5-4.fc27               rawhide 111 k
 ghostscript-core               x86_64 9.20-10.fc27               rawhide 4.5 M
 ghostscript-fonts              noarch 5.50-36.fc26               rawhide 328 k
 giflib                         x86_64 4.1.6-17.fc27              rawhide  44 k
 glib-networking                x86_64 2.50.0-2.fc26              rawhide 135 k
 graphite2                      x86_64 1.3.10-1.fc27              rawhide 118 k
 gsettings-desktop-schemas      x86_64 3.24.0-1.fc27              rawhide 575 k
 gssproxy                       x86_64 0.7.0-10.fc27              rawhide 106 k
 gstreamer1                     x86_64 1.12.1-1.fc27              rawhide 1.2 M
 gstreamer1-plugins-base        x86_64 1.12.1-1.fc27              rawhide 1.5 M
 gtk-update-icon-cache          x86_64 3.22.16-1.fc27             rawhide  32 k
 gtk2                           x86_64 2.24.31-4.fc27             rawhide 3.4 M
 gtk3                           x86_64 3.22.16-1.fc27             rawhide 4.4 M
 harfbuzz                       x86_64 1.4.6-1.fc27               rawhide 254 k
 harfbuzz-icu                   x86_64 1.4.6-1.fc27               rawhide  20 k
 hicolor-icon-theme             noarch 0.15-5.fc27                rawhide  45 k
 hunspell                       x86_64 1.5.4-2.fc26               rawhide 326 k
 hunspell-en-US                 noarch 0.20140811.1-6.fc26        rawhide 194 k
 hwdata                         noarch 0.302-1.fc27               rawhide 1.4 M
 hyphen                         x86_64 2.8.8-6.fc26               rawhide  30 k
 ilmbase                        x86_64 2.2.0-8.fc26               rawhide 104 k
 iso-codes                      noarch 3.75-1.fc27                rawhide 3.2 M
 jasper-libs                    x86_64 2.0.12-1.fc27              rawhide 161 k
 jbigkit-libs                   x86_64 2.1-6.fc26                 rawhide  51 k
 json-glib                      x86_64 1.2.8-1.fc27               rawhide 138 k
 keyutils                       x86_64 1.5.10-1.fc26              fedora   59 k
 lcms2                          x86_64 2.8-3.fc26                 rawhide 158 k
 libICE                         x86_64 1.0.9-9.fc27               rawhide  70 k
 libSM                          x86_64 1.2.2-5.fc26               rawhide  42 k
 libX11                         x86_64 1.6.5-2.fc27               rawhide 615 k
 libX11-common                  noarch 1.6.5-2.fc27               rawhide 165 k
 libXau                         x86_64 1.0.8-7.fc26               rawhide  33 k
 libXaw                         x86_64 1.0.13-5.fc26              rawhide 190 k
 libXcomposite                  x86_64 0.4.4-9.fc26               rawhide  26 k
 libXcursor                     x86_64 1.1.14-8.fc26              rawhide  33 k
 libXdamage                     x86_64 1.1.4-9.fc26               rawhide  24 k
 libXext                        x86_64 1.3.3-5.fc26               rawhide  42 k
 libXfixes                      x86_64 5.0.3-2.fc26               rawhide  22 k
 libXfont                       x86_64 1.5.2-2.fc26               rawhide 154 k
 libXft                         x86_64 2.3.2-5.fc26               rawhide  63 k
 libXi                          x86_64 1.7.9-2.fc26               rawhide  44 k
 libXinerama                    x86_64 1.1.3-7.fc26               rawhide  17 k
 libXmu                         x86_64 1.1.2-5.fc26               rawhide  74 k
 libXpm                         x86_64 3.5.12-2.fc26              rawhide  55 k
 libXrandr                      x86_64 1.5.1-2.fc26               rawhide  30 k
 libXrender                     x86_64 0.9.10-2.fc26              rawhide  30 k
 libXt                          x86_64 1.1.5-4.fc26               rawhide 179 k
 libXtst                        x86_64 1.2.3-2.fc26               rawhide  24 k
 libXv                          x86_64 1.0.11-2.fc26              rawhide  21 k
 libXxf86vm                     x86_64 1.1.4-4.fc26               rawhide  21 k
 libdatrie                      x86_64 0.2.9-4.fc26               rawhide  30 k
 libdrm                         x86_64 2.4.81-1.fc27              rawhide 156 k
 libepoxy                       x86_64 1.4.1-2.fc27               rawhide 199 k
 libev                          x86_64 4.24-2.fc26                rawhide  48 k
 libevent                       x86_64 2.0.22-3.fc27              rawhide 221 k
 libfontenc                     x86_64 1.1.3-4.fc26               rawhide  34 k
 libglvnd                       x86_64 1:0.2.999-20.20170620gitd850cdd.fc27
                                                                  rawhide  91 k
 libglvnd-egl                   x86_64 1:0.2.999-20.20170620gitd850cdd.fc27
                                                                  rawhide  45 k
 libglvnd-glx                   x86_64 1:0.2.999-20.20170620gitd850cdd.fc27
                                                                  rawhide 127 k
 libgusb                        x86_64 0.2.10-1.fc27              rawhide  46 k
 libicu                         x86_64 57.1-6.fc26                fedora  8.4 M
 libjpeg-turbo                  x86_64 1.5.1-2.fc27               rawhide 150 k
 liblockfile                    x86_64 1.09-5.fc26                rawhide  27 k
 libmodman                      x86_64 2.0.1-13.fc26              rawhide  32 k
 libnfsidmap                    x86_64 0.27-1.fc26                rawhide  52 k
 libnotify                      x86_64 0.7.7-2.fc26               rawhide  43 k
 libogg                         x86_64 2:1.3.2-6.fc26             rawhide  28 k
 libotf                         x86_64 0.9.13-8.fc26              rawhide  97 k
 libpciaccess                   x86_64 0.13.4-4.fc26              rawhide  29 k
 libpkgconf                     x86_64 1.3.7-1.fc27               rawhide  30 k
 libproxy                       x86_64 0.4.15-1.fc27              rawhide  66 k
 librsvg2                       x86_64 2.40.17-1.fc27             rawhide 134 k
 libsecret                      x86_64 0.18.5-3.fc26              rawhide 155 k
 libsoup                        x86_64 2.58.1-2.fc27              rawhide 406 k
 libthai                        x86_64 0.1.25-2.fc26              rawhide 198 k
 libtheora                      x86_64 1:1.1.1-15.fc26            rawhide 188 k
 libtiff                        x86_64 4.0.8-1.fc27               rawhide 179 k
 libtirpc                       x86_64 1.0.2-0.fc26               updates 105 k
 libverto-libev                 x86_64 0.2.6-7.fc26               rawhide  13 k
 libvisual                      x86_64 1:0.4.0-21.fc26            rawhide 141 k
 libvorbis                      x86_64 1:1.3.5-2.fc26             rawhide 193 k
 libwayland-client              x86_64 1.13.0-1.fc26              rawhide  34 k
 libwayland-cursor              x86_64 1.13.0-1.fc26              rawhide  22 k
 libwayland-server              x86_64 1.13.0-1.fc26              rawhide  41 k
 libwebp                        x86_64 0.6.0-2.fc26               rawhide 259 k
 libwmf-lite                    x86_64 0.2.8.4-50.fc26            rawhide  72 k
 libxcb                         x86_64 1.12-3.fc26                rawhide 212 k
 libxkbcommon-x11               x86_64 0.7.1-3.fc26               fedora   22 k
 libxshmfence                   x86_64 1.2-4.fc26                 rawhide  10 k
 libxslt                        x86_64 1.1.29-2.fc27              rawhide 251 k
 m17n-db                        noarch 1.7.0-8.fc26               rawhide 566 k
 m17n-lib                       x86_64 1.7.0-6.fc26               rawhide 191 k
 mesa-libEGL                    x86_64 17.1.4-1.fc27              rawhide 108 k
 mesa-libGL                     x86_64 17.1.4-1.fc27              rawhide 168 k
 mesa-libgbm                    x86_64 17.1.4-1.fc27              rawhide  46 k
 mesa-libglapi                  x86_64 17.1.4-1.fc27              rawhide  53 k
 mesa-libwayland-egl            x86_64 17.1.4-1.fc27              rawhide  28 k
 openjpeg2                      x86_64 2.1.2-4.fc26               rawhide 116 k
 opus                           x86_64 1.2.1-1.fc27               rawhide 196 k
 orc                            x86_64 0.4.26-2.fc26              rawhide 170 k
 pango                          x86_64 1.40.6-1.fc27              rawhide 281 k
 pixman                         x86_64 0.34.0-3.fc26              rawhide 251 k
 pkgconf                        x86_64 1.3.7-1.fc27               rawhide  30 k
 pkgconf-m4                     noarch 1.3.7-1.fc27               rawhide  13 k
 pkgconf-pkg-config             x86_64 1.3.7-1.fc27               rawhide  12 k
 poppler-data                   noarch 0.4.7-7.fc26               rawhide 2.2 M
 psmisc                         x86_64 22.21-9.fc26               rawhide 147 k
 quota                          x86_64 1:4.03-9.fc27              rawhide 201 k
 quota-nls                      noarch 1:4.03-9.fc27              rawhide  93 k
 rest                           x86_64 0.8.0-2.fc26               rawhide  65 k
 rpcbind                        x86_64 0.2.4-7.rc2.fc27           rawhide  66 k
 tcp_wrappers                   x86_64 7.6-85.fc26                rawhide  82 k
 urw-fonts                      noarch 3:2.4-23.fc26              rawhide 3.0 M
 webkitgtk4                     x86_64 2.16.4-1.fc26              fedora   12 M
 webkitgtk4-jsc                 x86_64 2.16.4-1.fc26              fedora  4.2 M
 xml-common                     noarch 0.6.3-45.fc26              rawhide  30 k
 xorg-x11-font-utils            x86_64 1:7.5-33.fc26              rawhide  81 k
Installing weak dependencies:
 dconf                          x86_64 0.26.0-3.fc27              rawhide  99 k
 webkitgtk4-plugin-process-gtk2 x86_64 2.16.4-1.fc26              fedora  9.3 M

Transaction Summary
================================================================================
Install  153 Packages
Upgrade    1 Package

Total download size: 135 M
Downloading Packages:
--------------------------------------------------------------------------------
Total                                           2.7 MB/s | 135 MB     00:50     
warning: /var/cache/dnf/rawhide-2d95c80a1fa0a67d/packages/emacs-25.2-2.fc27.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID f5282ee4: NOKEY
Importing GPG key 0x64DAB85D:
 Userid     : "Fedora 26 Primary (26) <fedora-26-primary@fedoraproject.org>"
 Fingerprint: E641 850B 77DF 4353 78D1 D7E2 812A 6B4B 64DA B85D
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-26-x86_64
Key imported successfully
Import of key(s) didn't help, wrong key(s)?
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.

Error: 


Public key for emacs-25.2-2.fc27.x86_64.rpm is not installedFailing package is: emacs-1:25.2-2.fc27.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-26-x86_64

Version-Release number of selected component (if applicable):

Fedora 26, upgrading to Rawhide.

The failing package seems to be
emacs-25.2-2.fc27.x86_64

How reproducible:

Only tried it once.

Steps to Reproduce:

0. Install Fedora 26 (eg with Anaconda).
1. # dnf install fedora-repos-rawhide
2. Edit /etc/yum.repos.d/fedora-rawhide.repo to enable the repo.
3. # dnf install bash dnf dnf-plugins-core emacs mlocate net-tools nfs-utils ntp sudo telnet

Actual results:

See above.
Comment 1 Peter Robinson 2017-07-11 10:41:48 EDT
>  Userid     : "Fedora 26 Primary (26) <fedora-26-primary@fedoraproject.org>"
>  Fingerprint: E641 850B 77DF 4353 78D1 D7E2 812A 6B4B 64DA B85D
>  From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-26-x86_64

> file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-26-x86_64

That's not the F-27 key.

> 0. Install Fedora 26 (eg with Anaconda).
> 1. # dnf install fedora-repos-rawhide
> 2. Edit /etc/yum.repos.d/fedora-rawhide.repo to enable the repo.
> 3. # dnf install bash dnf dnf-plugins-core emacs mlocate net-tools nfs-utils
> ntp sudo telnet

I can see the F-27 key, the key in fedora-rawhide.repo says:
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch

Which means you'll be getting the F-26 key and all F-27 content is signed with the F-27 key but it'll try to use the f26 key because $releasever is still 26. 

You should do distro-sync not the above procedure. Or add 1.1 "dnf upgrade fedora-re*" but it really is an ugly way to do it and YMMV
Comment 2 Richard W.M. Jones 2017-07-17 08:25:41 EDT
Let's do distro-sync instead ...
Comment 3 Richard W.M. Jones 2017-07-17 09:10:18 EDT
I still think there's something wrong here:

---
$ sudo dnf install texi2html --enablerepo=rawhide --best
Last metadata expiration check: 0:00:49 ago on Mon 17 Jul 2017 14:06:43 BST.
Package texi2html-5.0-5.fc26.noarch is already installed, skipping.
Dependencies resolved.
================================================================================
 Package            Arch            Version              Repository        Size
================================================================================
Upgrading:
 texi2html          noarch          5.0-6.fc27           rawhide          535 k

Transaction Summary
================================================================================
Upgrade  1 Package

Total download size: 535 k
Is this ok [y/N]: y
Downloading Packages:
texi2html-5.0-6.fc27.noarch.rpm                 1.0 MB/s | 535 kB     00:00    
--------------------------------------------------------------------------------
Total                                           428 kB/s | 535 kB     00:01     
warning: /var/cache/dnf/rawhide-2d95c80a1fa0a67d/packages/texi2html-5.0-6.fc27.noarch.rpm: Header V3 RSA/SHA256 Signature, key ID f5282ee4: NOKEY
Importing GPG key 0x64DAB85D:
 Userid     : "Fedora 26 Primary (26) <fedora-26-primary@fedoraproject.org>"
 Fingerprint: E641 850B 77DF 4353 78D1 D7E2 812A 6B4B 64DA B85D
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-26-x86_64
Is this ok [y/N]: y
Key imported successfully
Import of key(s) didn't help, wrong key(s)?
---

It's using the Fedora 26 key for Rawhide, but the Fedora 27 key *is*
installed:

$ sudo dnf install /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-27-x86_64
Last metadata expiration check: 0:19:23 ago on Mon 17 Jul 2017 13:48:28 BST.
Package fedora-repos-26-1.noarch is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!

It's using the wrong key for whatever reason.
Comment 4 Kevin Fenzi 2017-07-20 19:59:27 EDT
It's using the wrong key because it has: 

gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch

which resolves to 26 on your f26 box. 

I'm not sure what the best answer here is. I guess we could have a rawhide key in the older repos, but it means updating them once we branch and make a new key.
Comment 5 Richard W.M. Jones 2017-07-21 03:22:27 EDT
I also have a file /etc/yum.repos.d/fedora-rawhide.repo which has
the gpgkey line as in comment 4.  Perhaps it could use:

gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-27-$basearch

Or another idea:

gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-rawhide-$basearch

plus there could be a symlink created in the filesystem?
Comment 6 Sergio Monteiro Basto 2017-07-21 06:27:41 EDT
anyway this should be an fedora-repos package problem .

please see bug #1456079 and bug #1364581
Comment 7 Kevin Fenzi 2017-07-22 16:55:22 EDT
Yeah, lets close this in favor of #1456079 which is the same issue really...

*** This bug has been marked as a duplicate of bug 1456079 ***

Note You need to log in before you can comment on or make changes to this bug.