Bug 1469667 - dnf should recommend sqlite package so tab completion works correctly
dnf should recommend sqlite package so tab completion works correctly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Igor Gnatenko
Fedora Extras Quality Assurance
: EasyFix, Triaged, UserExperience
: 1479330 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 11:15 EDT by Matthew Miller
Modified: 2018-01-03 10:08 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-01-03 10:08:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2017-07-11 11:15:19 EDT
Description of problem:

/usr/share/bash-completion/completion/dnf includes references to the sqlite3 command. Without that installed, related completions do not... complete.


Version-Release number of selected component (if applicable):

dnf-2.5.1-1.fc26.noarch

How reproducible:

inherent

Steps to Reproduce:
1. Install Fedora Workstation with default parameters
2. Try to tab complete something like `dnf upgrade sq[TAB]

Actual results:

Nothing

Expected results:

List of packages starting with sq

Additional info:

Install sqlite and watch the results above change.

Recommendation:

Add "Recommends: sqlite" or "Recommends: /usr/bin/sqlite3" to DNF package so sqlite gets pulled in. Please also check for other commands that might be used in the dnf completion file and address similarly.
Comment 1 Igor Gnatenko 2018-01-03 10:08:59 EST
*** Bug 1479330 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.