Bug 1469682 - Incomplete Kernel installation on RHEL 6
Incomplete Kernel installation on RHEL 6
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhnsd (Show other bugs)
6.10
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Tomáš Kašpárek
Red Hat Satellite QA List
:
Depends On: 1383668
Blocks: 1504706 1541321
  Show dependency treegraph
 
Reported: 2017-07-11 11:45 EDT by Jan Dobes
Modified: 2018-06-19 01:14 EDT (History)
16 users (show)

See Also:
Fixed In Version: rhnsd-4.9.3-6-el6
Doc Type: Bug Fix
Doc Text:
Kernel installations using *rhnsd* complete successfully If a kernel installation scheduled by the kernel was run using the *Red Hat Network Daemon* (rhnsd), the installation of the kernel sometimes stopped before completion. This issue has been fixed and kernel installations using *rhnsd* now complete successfully.
Story Points: ---
Clone Of: 1383668
Environment:
Last Closed: 2018-06-19 01:14:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3163151 None None None 2018-04-17 08:23 EDT
Red Hat Product Errata RHBA-2018:1878 None None None 2018-06-19 01:14 EDT

  None (edit)
Comment 2 Tomas Lestach 2017-07-12 04:53:18 EDT
Switching to MODIFIED as I see we have a patch in upstream.
Comment 16 Martin Korbel 2018-03-21 04:38:19 EDT
VERIFIED on rhnsd-4.9.3-6.el6

I could not reproduce of the problem with kernel panic. In my case, rhnsd-4.9.3-5.el6 did not update /boot/grub/grub.conf (after reboot, the system still use the old kernel, but the packages are installed).

The problem is fixed in new version. rhnsd update /boot/grub/grub.conf (after reboot, the system use new version of kernel).
Comment 19 errata-xmlrpc 2018-06-19 01:14:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1878

Note You need to log in before you can comment on or make changes to this bug.