Bug 1469706 - Leftover /opt/rh/rh-nodejs8/root/usr/share/doc/rh-nodejs8-nodejs/npm after uninstallation
Leftover /opt/rh/rh-nodejs8/root/usr/share/doc/rh-nodejs8-nodejs/npm after un...
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: rh-nodejs8 (Show other bugs)
rh-nodejs8
Unspecified Unspecified
low Severity low
: alpha
: 3.0
Assigned To: Zuzana Svetlikova
Mirosław Zalewski
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 12:38 EDT by Miroslav Hradílek
Modified: 2017-10-24 05:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-24 05:56:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3029 normal SHIPPED_LIVE new packages: rh-nodejs8 2017-10-24 09:37:28 EDT

  None (edit)
Description Miroslav Hradílek 2017-07-11 12:38:20 EDT
Description of problem:
When I Install rh-nodejs8-nodejs-docs the directory is created in
/opt/rh/rh-nodejs8/root/usr/share/doc/rh-nodejs8-nodejs/npm

but it does not belong to the docs package and therefore is not removed after package removal.

Version-Release number of selected component (if applicable):
Unreleased rh-nodejs8-nodejs-docs-8.1.2-7.el7.noarch.rpm
Comment 3 Mirosław Zalewski 2017-09-21 03:01:10 EDT
Issue at hand has been fixed in the meantime.

Test was still failing because files owned by some packages (rh-nodejs8-nodejs-bson, rh-nodejs8-nodejs-mongodb, rh-nodejs8-nodejs-mongodb-core, rh-nodejs8-nodejs-require_optional and rh-nodejs8-nodejs-resolve-from) were not treated as belonging to rh-nodejs8 collection. That issue was resolved as well. Test passes on x86_64 and s390x. See Beaker job 2058021.

However, it still fails on aarch64 and ppc64le. The reason is that rh-nodejs8-runtime package does not own directory /opt/rh/rh-nodejs8/root/usr/lib64/ on these architectures. New bugilla issue was created to track progress on that problem: Bug #1493894.

Setting as VERIFIED, since there is hardly any more work to do in this ticket.
Comment 5 errata-xmlrpc 2017-10-24 05:56:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3029

Note You need to log in before you can comment on or make changes to this bug.