Bug 1469717 - [GSS] CTDB fails to operate with too many open files warning
[GSS] CTDB fails to operate with too many open files warning
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: ctdb (Show other bugs)
3.2
Unspecified Linux
unspecified Severity high
: ---
: RHGS 3.3.0
Assigned To: Guenther Deschner
Vivek Das
:
Depends On:
Blocks: 1417151
  Show dependency treegraph
 
Reported: 2017-07-11 13:40 EDT by Pan Ousley
Modified: 2017-09-21 00:47 EDT (History)
7 users (show)

See Also:
Fixed In Version: samba-4.6.3-5.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-21 00:47:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pan Ousley 2017-07-11 13:40:48 EDT
Description of problem:

When more then 1024 smbd processes try to connect to ctdb, ctdb may fail to respond, as it only allows 1024 open file handles (the system default). Samba's startup script alters the system limit to a higher value, and so should ctdb.

Actual results: ctdb fails to respond due to an insufficient open file handle limit of 1024.

Expected results: ctdb should alter the system limit to a higher value.
Comment 11 errata-xmlrpc 2017-09-21 00:47:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2780

Note You need to log in before you can comment on or make changes to this bug.