This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1469737 - "KeyError: 'guestIds'" occurs after trigger guest when virt-who run against stage candlepin 2.0
"KeyError: 'guestIds'" occurs after trigger guest when virt-who run against s...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-who (Show other bugs)
7.4
x86_64 Linux
high Severity medium
: rc
: ---
Assigned To: candlepin-bugs
Eko
: Triaged, ZStream
Depends On: 1458674
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 14:29 EDT by Chris Snyder
Modified: 2017-08-01 07:32 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the virt-who service expected an outdated data format from the hypervisor check-ins. Consequently, virt-who in some cases failed to send the guest-hypervisor mappings and logged a "KeyError: 'guestIds'" message. The data format expected by virt-who has been updated, which prevents the described problem from occurring.
Story Points: ---
Clone Of: 1458674
Environment:
Last Closed: 2017-08-01 07:32:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github virt-who/virt-who/pull/75 None None None 2017-07-11 14:29 EDT

  None (edit)
Comment 3 yuefliu 2017-07-24 02:22:54 EDT
Verified the bug with virt-who-0.19-6.el7_4.noarch, no "KeyError: 'guestIds'" error reproduce when the first time start virt-who to send mapping or make any trigger option to host/guest.
Comment 5 errata-xmlrpc 2017-08-01 07:32:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2336

Note You need to log in before you can comment on or make changes to this bug.