Bug 1469792 - 7.4-alt: avc deny starting docker
7.4-alt: avc deny starting docker
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: container-selinux (Show other bugs)
7.4-Alt
ppc64le Linux
high Severity high
: rc
: ---
Assigned To: Lokesh Mandvekar
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks: 1381083
  Show dependency treegraph
 
Reported: 2017-07-11 16:46 EDT by CAI Qian
Modified: 2017-09-05 06:39 EDT (History)
11 users (show)

See Also:
Fixed In Version: container-selinux-2.21-2.gitba103ac.el7_4
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-05 06:39:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CAI Qian 2017-07-11 16:46:31 EDT
Description of problem:
# systemctl start docker

# ausearch -m avc
time->Tue Jul 11 16:43:26 2017
type=PROCTITLE msg=audit(1499805806.558:344): proctitle=2F7573722F7362696E2F69707461626C6573002D2D77616974002D4400464F5257415244002D6900646F636B657230002D6F00646F636B657230002D6A0044524F50
type=SYSCALL msg=audit(1499805806.558:344): arch=c0000015 syscall=11 success=yes exit=0 a0=c42055ae40 a1=c4203beea0 a2=c4203bef00 a3=0 items=0 ppid=13678 pid=13735 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="iptables" exe="/usr/sbin/xtables-multi" subj=system_u:system_r:iptables_t:s0 key=(null)
type=AVC msg=audit(1499805806.558:344): avc:  denied  { read } for  pid=13735 comm="iptables" path="net:[4026531872]" dev="nsfs" ino=4026531872 scontext=system_u:system_r:iptables_t:s0 tcontext=system_u:system_r:container_runtime_t:s0 tclass=file permissive=0

# audit2allow -a


#============= iptables_t ==============
allow iptables_t container_runtime_t:file read;


Version-Release number of selected component (if applicable):
docker-1.12.6-40.1.gitf55a118.el7.ppc64le
container-selinux-2.19-2.1.el7.noarch

How reproducible:
always
Comment 3 Yaakov Selkowitz 2017-07-11 17:33:31 EDT
(In reply to CAI Qian from comment #0)
> type=SYSCALL msg=audit(1499805806.558:344): arch=c0000015 syscall=11
> success=yes exit=0 a0=c42055ae40 a1=c4203beea0 a2=c4203bef00 a3=0 items=0
> ppid=13678 pid=13735 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0
> egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="iptables"
> exe="/usr/sbin/xtables-multi" subj=system_u:system_r:iptables_t:s0 key=(null)
> type=AVC msg=audit(1499805806.558:344): avc:  denied  { read } for 
> pid=13735 comm="iptables" path="net:[4026531872]" dev="nsfs" ino=4026531872
> scontext=system_u:system_r:iptables_t:s0
> tcontext=system_u:system_r:container_runtime_t:s0 tclass=file permissive=0

This looks a lot like Fedora bug 1234757, which would indicate that may be needed in selinux-policy as well.
Comment 4 Daniel Walsh 2017-07-11 17:42:47 EDT
Right this is not a new issue, it is just an issue with iptables and requires a new selinux-policy package.
Comment 5 Daniel Walsh 2017-07-11 17:43:31 EDT
Lukas can we get this updated in the selinux-policy package for pegas.
Comment 10 Josh Boyer 2017-07-27 06:17:19 EDT
Switching needinfo to Cai.
Comment 18 errata-xmlrpc 2017-09-05 06:39:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2610

Note You need to log in before you can comment on or make changes to this bug.