Bug 1469799 - Needs rebuild for Samba 4.7
Needs rebuild for Samba 4.7
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: freeipa (Show other bugs)
rawhide
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: IPA Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks: AlphaBlocker/F27AlphaBlocker
  Show dependency treegraph
 
Reported: 2017-07-11 17:00 EDT by Adam Williamson
Modified: 2017-07-15 03:31 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-15 03:31:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2017-07-11 17:00:16 EDT
I believe this is known already, but wanted a bug # to track it (so I can link to the issue from openQA).

FreeIPA cannot be properly installed in current Fedora Rawhide due to dependency issues with Samba, e.g. freeipa-server-trust-ad depending on libsmbldap.so.0 (the soname was bumped to libsmbldap.so.2 in Samba 4.7).

It seems an attempt to rebuild against Samba 4.7 was made, but failed on ppc64le:

https://koji.fedoraproject.org/koji/buildinfo?buildID=916829

This very likely constitutes an Alpha blocker as it will probably result in FreeIPA not being installable (can't tell for sure right now as the test fails earlier, due to a bug in rolekit).
Comment 1 Alexander Bokovoy 2017-07-12 02:04:47 EDT
All patches are committed to freeipa package git already. We are waiting for gcc/glibc fixes to be done with ifunc crashes on ppc64le. Without that there is no way to rebuild FreeIPA in rawhide.

However, even when that rebuild completes, FreeIPA will still be non-functioning on Rawhide, thanks to curl dropping support for NSS. See https://bugzilla.redhat.com/show_bug.cgi?id=1455561#c5 for details.
Comment 2 Alexander Bokovoy 2017-07-15 03:31:26 EDT
I was successful in completing Rawhide build after bug 1470115 was solved. I'm closing this bug as the package is rebuilt. However, my comment #1 stands but there is another bug for that.

Note You need to log in before you can comment on or make changes to this bug.