Bug 146980 - Excessive and inconsistent outlining of Buecurve icons
Excessive and inconsistent outlining of Buecurve icons
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-artwork (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-03 05:38 EST by Joachim Frieben
Modified: 2013-03-13 00:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-10 14:16:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Panel screenshot featuring "new" and "old" Bluecurve icons (8.13 KB, image/png)
2005-02-03 05:40 EST, Joachim Frieben
no flags Details
Panel screenshot featuring Bluecurve icons with and without black outline (4.65 KB, image/png)
2005-02-03 15:35 EST, Joachim Frieben
no flags Details
Panel icon screenshot for "Bluecurve" theme (5.86 KB, image/png)
2005-05-01 06:36 EDT, Joachim Frieben
no flags Details
Panel icon screenshot for "Clearlooks" theme (6.28 KB, image/png)
2005-05-01 06:37 EDT, Joachim Frieben
no flags Details
Obsolete. (9.30 KB, image/png)
2005-05-02 14:54 EDT, Joachim Frieben
no flags Details
Obsolete. (7.20 KB, image/png)
2005-05-02 14:55 EDT, Joachim Frieben
no flags Details
Full panel screenshot for "Bluecurve" theme (24 pixels) (9.85 KB, image/png)
2005-05-02 14:59 EDT, Joachim Frieben
no flags Details
Full panel screenshot for "Clearlooks" theme (24 pixels) (9.39 KB, image/png)
2005-05-02 15:00 EDT, Joachim Frieben
no flags Details
Magnified panel icon screenshot for "Bluecurve" theme (24 pixels) (4.95 KB, image/png)
2005-05-02 15:06 EDT, Joachim Frieben
no flags Details
Magnified panel icon screenshot for "Clearlooks" theme (24 pixels) (4.92 KB, image/png)
2005-05-02 15:07 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2005-02-03 05:38:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20050109 Epiphany/1.4.7

Description of problem:
After installing the current development version of Fedora Core, one
immediately notices the altered appearance of (most of) the Bluecurve
icons. Compared to the familiar Bluecurve look, they exhibit excessive
black outlines which IMHO deteriorate the "visual experience".
Btw, as can bee seen from the attached screenshot, the modifications
are not even implemented in a consistent manner, e.g., in the case of
the "Terminal" and the "Web browser" icons, the old version is used.
Please consider returning to the previous style or, at least, include
both icon sets (traditional/new) leaving the choice up to the user .
This approach had already been adopted for the window border styles.

Version-Release number of selected component (if applicable):
redhat-artwork-0.120-4

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora Core development version (02/02/05).
2. Log in to GNOME session.
3. Check panel/menus.
    

Actual Results:  "Improved" Bluecurve icons instead of the standard
Bluecurve ones are displayed.

Expected Results:  In the best of all worlds, the very well designed
"classic" Bluecurve icons would have been used.

Additional info:

This must be a very recent change. I haven't found any corresponding
information neither in the Changelog nor by querying the RPM change
history. FC3 with all updates applied still looks "normal".
Comment 1 Joachim Frieben 2005-02-03 05:40:47 EST
Created attachment 110586 [details]
Panel screenshot featuring "new" and "old" Bluecurve icons
Comment 2 Joachim Frieben 2005-02-03 15:33:25 EST
The issue seems to be related to an icon rendering bug. When the icon
size is changed from 48 to 24 pixels and afterwards back to 48, the
usual aspect is restored. Consequently, the RFE can be dropped, and
the issue should be reassigned as a GNOME panel bug. See the
attachment where the right 3 icons have been "treated" accordingly,
whereas the left 2 icons are displayed with a noticeable black outline.
Comment 3 Joachim Frieben 2005-02-03 15:35:06 EST
Created attachment 110615 [details]
Panel screenshot featuring Bluecurve icons with and without black outline
Comment 4 Mark McLoughlin 2005-04-27 06:33:21 EDT
Are you still seeing this with latest rawhide ?
Comment 5 Joachim Frieben 2005-04-29 01:49:08 EDT
All icons are outlined consistently now. The outline is pretty strong, but as a
matter of fact, I realized later on that the icons in the Gnome menus exhibited
the same prominent outlining already a long time ago (must have been the time of
FC1), whereas the panel icons kept being outlined rather mildly. In this
respect, the global aspect is now actually more consistent than it was for
RHEL4, FC3 and earlier releases. Moreover, the altered appearance is/was not due
to a changed Bluecurve icon set but rather due to a modified icon rendering
process in the Gnome panel itself.
Comment 6 Joachim Frieben 2005-05-01 06:34:16 EDT
I do have an additional comment on this topic. I have had a look at the new
"Clearlooks" theme and interestingly, there is a noticeable difference between
the panel icon rendering done by "Bluecurve" and the former which contributes to
the visual effect described before. The "Bluecurve" GTK2 engine seems to smear
out panel icons which becomes clearly visible when comparing screenshots for the
2 themes.
Comment 7 Joachim Frieben 2005-05-01 06:36:30 EDT
Created attachment 113903 [details]
Panel icon screenshot for "Bluecurve" theme
Comment 8 Joachim Frieben 2005-05-01 06:37:37 EDT
Created attachment 113904 [details]
Panel icon screenshot for "Clearlooks" theme
Comment 9 Mark McLoughlin 2005-05-02 03:32:41 EDT
Moving back to redhat-artwork
Comment 10 John (J5) Palmieri 2005-05-02 11:31:06 EDT
The screenshots to me look like the bluring effect is happening because the
panel is slightly larger in the clearlooks screenshot thereby causing the icons
to stretch.  This does not happen on my box simply switching themes (then again
I have my panel set at a custom size).  Will try on a fresh user.  In the
meantime Joachim, can you confirm that the panel is indeed changing size
slightly when you change themes. Also take a screenshot of the whole panel. 
This could be an effect of some applet that gets bigger in the clearlooks theme
due to boarders or something like that.
Comment 11 Joachim Frieben 2005-05-02 14:52:30 EDT
I have made 2 screenshots of the icon area for a panel size of 24 pixels, and
the "Bluecurve" panel bar actually is 1 pixel higher than its "Clearlooks"
counterpart (see attached screenshots). For the "Bluecurve" theme, the panel
size cannot be reduced any further with a visible effect. The absolute lower
limit is 23 pixels anyway. Btw, the situation is just the opposite of the one
you describe: the blurring takes place in the "Bluecurve" case, not the
"Clearlooks" one.
Comment 12 Joachim Frieben 2005-05-02 14:54:56 EDT
Created attachment 113934 [details]
Obsolete.
Comment 13 Joachim Frieben 2005-05-02 14:55:58 EDT
Created attachment 113935 [details]
Obsolete.
Comment 14 Joachim Frieben 2005-05-02 14:59:14 EDT
Created attachment 113936 [details]
Full panel screenshot for "Bluecurve" theme (24 pixels)
Comment 15 Joachim Frieben 2005-05-02 15:00:17 EDT
Created attachment 113937 [details]
Full panel screenshot for "Clearlooks" theme (24 pixels)
Comment 16 Joachim Frieben 2005-05-02 15:06:17 EDT
Created attachment 113939 [details]
Magnified panel icon screenshot for "Bluecurve" theme (24 pixels)
Comment 17 Joachim Frieben 2005-05-02 15:07:00 EDT
Created attachment 113940 [details]
Magnified panel icon screenshot for "Clearlooks" theme (24 pixels)
Comment 18 John (J5) Palmieri 2005-05-02 15:11:09 EDT
Found the culprit.  The menu bar applet has a padding in the bluecurve theme
that expands the panel to 25 pixels so it is not evident on panels set to 25
pixels or above.  Reassigning to the panel.  Mark feel free to reasign to me if
you think it needs to be fixed in the bluecurve theme.
Comment 19 Mark McLoughlin 2005-05-03 04:23:10 EDT
Well, the "fix" to Bluecurve is:

 style "bluecurve-menu-item" = "bluecurve-default"
 {
   xthickness = 3
-  ythickness = 4
+  ythickness = 3


If we don't do that (e.g. presumably there was a reason for ythickness = 4), I
don't think there's much else we can do - cropping the menubar would look bad,
not scaling the icons would look bad ...
Comment 20 Joachim Frieben 2005-05-10 13:42:15 EDT
Great - the icon blurring issue is resolved with "redhat-artwork-0.122-8".

Note You need to log in before you can comment on or make changes to this bug.