Bug 1469805 - add-base-rhel-tools-path.patch not fully applied in LinuxtoolsProcessFactory.java, so rejected hunk #3 appears in the rpm and srpm
add-base-rhel-tools-path.patch not fully applied in LinuxtoolsProcessFactory....
Status: CLOSED ERRATA
Product: DevTools
Classification: Red Hat
Component: rh-eclipse47 (Show other bugs)
rh-eclipse47
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 1.0
Assigned To: Mat Booth
Václav Kadlčík
Robert Krátký
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 17:22 EDT by Nick Boldt
Modified: 2017-08-15 11:05 EDT (History)
5 users (show)

See Also:
Fixed In Version: rh-eclipse47-eclipse-linuxtools-6.0.0-1.4.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-15 11:05:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:2476 normal SHIPPED_LIVE rh-eclipse47 bug fix and enhancement update 2017-08-15 15:01:40 EDT

  None (edit)
Description Nick Boldt 2017-07-11 17:22:59 EDT
Description of problem:

.orig file appears in the .rpm and .srpm for eclipse-linuxtools 6.0.0-1.3

Version-Release number of selected component (if applicable):


How reproducible: see https://errata.devel.redhat.com/rpmdiff/show/177016?result_id=4852998


Steps to Reproduce:
1. see https://errata.devel.redhat.com/rpmdiff/show/177016?result_id=4852998

Actual results:

.orig files appear in the .srpm and .rpm


Expected results:

No .orig files. 


Additional info:

Here's a fix to the patch file that should avoid this .orig leftover file.

http://pkgs.devel.redhat.com/cgit/rpms/eclipse-linuxtools/commit/eclipse-linuxtools.spec?h=devtools-1.0-rh-eclipse47-rhel-7&id=a57eee6709699a361cd3ecb5f766616cfa2643cb
Comment 1 Nick Boldt 2017-07-11 17:25:24 EDT
I was unable to kick the above change in a brew build (not sure how, `rhpkg build` didn't work for me) but rgrunber kicked it for me.

https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=13635779
Comment 2 Nick Boldt 2017-07-12 13:02:42 EDT
Looking at https://errata.devel.redhat.com/rpmdiff/show/177443?result_id=4867336 I see that my fix has been applied and the .orig file is gone.
Comment 5 errata-xmlrpc 2017-08-15 11:05:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2476

Note You need to log in before you can comment on or make changes to this bug.