Bug 1469827 - Unmounting a USB drive hangs
Unmounting a USB drive hangs
Status: CLOSED DUPLICATE of bug 1469789
Product: Fedora
Classification: Fedora
Component: Thunar (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 18:31 EDT by Sam Varshavchik
Modified: 2017-07-20 17:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-20 17:50:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Varshavchik 2017-07-11 18:31:03 EDT
Description of problem:

Clicking on the little "up" arrow next to a mounted usb-storage device, which normally unmounts it, hangs thunar.

This appears to be happening only in the F26 build of Thunar. The same version-release on F25 is fine.

Version-Release number of selected component (if applicable):

Thunar-1.6.11-1.fc26.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Update F25 to F26
2. Log in, insert a USB thumb drive. Run thunar
3. Click on the up arrow to unmount the usb-storage device

Actual results:

The thunar process hangs and no longer responds to any input.

Expected results:

The device is unmounted.

Additional info:

straceing the Thunar process shows:

futex(0x7fd7fe16dae0, FUTEX_WAKE_PRIVATE, 1) = 0
write(9, "\1\0\0\0\0\0\0\0", 8)         = 8
futex(0x560aed100380, FUTEX_WAKE_PRIVATE, 1) = 1
futex(0x560aed1000a0, FUTEX_WAKE_PRIVATE, 1) = 1
futex(0x560aed0f80a8, FUTEX_WAKE_PRIVATE, 1) = 1
eventfd2(0, EFD_CLOEXEC|EFD_NONBLOCK)   = 17
futex(0x7fd7fe8f6218, FUTEX_WAIT_PRIVATE, 2, NULL) = -1 EAGAIN (Resource temporarily unavailable)
futex(0x7fd7fe8f6218, FUTEX_WAKE_PRIVATE, 1) = 0
futex(0x560aed102fb0, FUTEX_WAKE_PRIVATE, 1) = 0
write(9, "\1\0\0\0\0\0\0\0", 8)         = 8
futex(0x560aed100380, FUTEX_WAKE_PRIVATE, 1) = 1
futex(0x560aed1000a0, FUTEX_WAKE_PRIVATE, 1) = 1
futex(0x560aed0f80a8, FUTEX_WAKE_PRIVATE, 1) = 1
poll([{fd=17, events=POLLIN}], 1, 25000 <unfinished ...>) = ?

and it never returns from poll().

Looking in /proc, fd 17 is an anonymous eventfd file descriptor.
Comment 1 Kevin Fenzi 2017-07-20 17:50:10 EDT

*** This bug has been marked as a duplicate of bug 1469789 ***

Note You need to log in before you can comment on or make changes to this bug.