Bug 1469902 - Libguestfs should pass copyonread flag through to the libvirt XML
Libguestfs should pass copyonread flag through to the libvirt XML
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs (Show other bugs)
7.4
x86_64 Linux
high Severity medium
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
: Regression, ZStream
Depends On: 1466563
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-12 00:22 EDT by Jaroslav Reznik
Modified: 2017-08-01 07:30 EDT (History)
14 users (show)

See Also:
Fixed In Version: libguestfs-1.36.3-6.el7_4.1
Doc Type: Bug Fix
Doc Text:
Previously, when the libvirt back end to libguestfs was used, the "copyonread" flag was not passed through, which caused performance problems for libguestfs utilities. Notably, the virt-v2v utility was slowed significantly when converting guests from the VMware hypervisor. With this update, "copyonread" is correctly respected when running libguestfs utilities using the libvirt back end. As a result, the described problem no longer occurs.
Story Points: ---
Clone Of: 1466563
Environment:
Last Closed: 2017-08-01 07:30:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2017-07-12 00:22:45 EDT
This bug has been copied from bug #1466563 and has been proposed to be backported to 7.4 z-stream (EUS).
Comment 7 kuwei@redhat.com 2017-07-19 08:07:19 EDT
Thanks rjones and Pino for your details explain.And with ‘virt-v2v -v -x’  we can see libvirt XML which  has:

  <driver name="qemu" .... copy_on_read="on" />


So,from comment 4/5/6 , move the bug to VERIFIED.
Comment 8 kuwei@redhat.com 2017-07-21 07:18:52 EDT
To verify it again, compare the same test convert a guest from vmware to kvm with a linux and a windows (i.e. same input hypervisor, same guest, and same output) with both libguestfs-1.36.3-6.el7.x86_64 and libguestfs-1.36.3-6.el7_4.2.x86_64, and to make a conclude.

Scenario 1:
with below builds:
qemu-kvm-rhev-2.9.0-14.el7.x86_64
kernel-3.10.0-681.el7.x86_64
libvirt-3.2.0-14.el7.x86_64
virt-v2v-1.36.3-6.el7.x86_64
libvirt-2.0.0-10.el7.x86_64

Time:
1:rhel7.3 2210.3s
2:windows10 1798.0

Scenario 2:
qemu-kvm-rhev-2.9.0-16.el7_4.2.x86_64
libvirt-3.2.0-14.el7_4.2.x86_64
libguestfs-1.36.3-6.el7_4.2.x86_64
virt-v2v-1.36.3-6.el7_4.2.x86_64

time: 
1:rhel7.3  1314.7s 
2:windows10 1080.7s

So, now the version virt-v2v-1.36.3-6.el7_4.2.x86_64 has a better rate than the version virt-v2v-1.36.3-6.el7.x86_64.
Comment 9 errata-xmlrpc 2017-08-01 07:30:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2332

Note You need to log in before you can comment on or make changes to this bug.