Bug 146992 - cyrus-imapd autocreate - new features - RFE
cyrus-imapd autocreate - new features - RFE
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: cyrus-imapd (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-03 09:57 EST by Craig White
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-10 16:03:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Craig White 2005-02-03 09:57:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
patch for options...

autocreate_sieve_script: 
autocreate_sieve_compiledscript: 
generate_compiled_sieve_script: 

apparently invoca rpms now include this patch

http://email.uoa.gr/projects/cyrus/autocreate/README.autocreate-cyrus-2.2

http://email.uoa.gr/download/cyrus/cyrus-imapd-2.2.10/cyrus-imapd-2.2.10-autocreate-0.9.1.diff

This is valuable since it allows for automated sieve scripts enabled
for new users - i.e. when spamassassin tags an email with a flag,
sieve script could move the spam mail to a subfolder or send to /dev/null 

Otherwise, automated script delivery for new users on system is a
massive perl/shell script hack.


Version-Release number of selected component (if applicable):
cyrus-imapd-2.2.10

How reproducible:
Always

Steps to Reproduce:
1. Install cyrus-imapd rpms and configure
2. Configure /etc/imapd.conf with:

autocreate_sieve_script: /etc/default_sieve_script
autocreate_sieve_compiledscript: /etc/default_sieve_script.bc
generate_compiled_sieve_script: 1

3. Those those files exist - nothing happens when a new user logs on
for the first time though these options do work:
createonpost: 1
autocreateinboxfolders: Sent Items|SPAMBOX|VIRUSBOX|Drafts|Deleted Items
autosubscribeinboxfolders: Sent Items|SPAMBOX|VIRUSBOX|Drafts|Deleted
Items
autocreatequota: 1024000

The configuration options listed in #2 above are not referenced in
/usr/share/doc/cyrus-imapd-2.2.10/README.autocreate
/usr/share/doc/cyrus-imapd-2.2.10/README.autosieve

Actual Results:  nothing

Expected Results:  new user logs on for first time, sieve script is
located, copied into proper place and activated

Additional info:
Comment 1 John Dennis 2005-02-10 16:03:33 EST
this will appear in the next fedora release, FC4

Note You need to log in before you can comment on or make changes to this bug.