Bug 1469959 - httpd update cleaned out /etc/sysconfig
httpd update cleaned out /etc/sysconfig
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
24
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Luboš Uhliarik
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-12 03:25 EDT by customercare
Modified: 2017-07-23 17:51 EDT (History)
5 users (show)

See Also:
Fixed In Version: httpd-2.4.27-2.fc25 httpd-2.4.27-2.fc26 httpd-2.4.27-3.fc24
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-23 17:51:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description customercare 2017-07-12 03:25:02 EDT
Description of problem:

the latest update to httpd-2.4.26-1 (this night ) cleaned out an old httpd config file /etc/sysconfig/httpd . I believe this is a case of accidently housekeeping.

The result was, that a systemd private httpd.service file, which still refered to /etc/sysconfig/httpd, could not be started by systemd due to the missing file.

Ofcourse we will remove the reference to it, as this file is not needed at all.

Question: 

I don't get, why the removal had to happen at all in this update.
The control about /e/s/httpd was released with httpd-2.4.19*. 
Why got it deleted with 2.4.26 ? thats a lot of updates later.

RPM should have had removed it while updating, not months later.


Version-Release number of selected component (if applicable):

httpd-2.4.26-1

Actual results:

A file got removed the package was no longer responsible for.

Expected results:

Leave files, you no longer own, to themselves.

Additional info:

Just to give you an example of the private httpd.service file :

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
[~]# cat /etc/systemd/system/httpd.service 
[Unit]
Description=The Apache HTTP Server (prefork MPM)
After=syslog.target network.target remote-fs.target nss-lookup.target

[Service]
Type=forking
PIDFile=/var/run/httpd/httpd.pid
LimitNOFILE=1000000
EnvironmentFile=/etc/sysconfig/httpd
ExecStart=/usr/sbin/httpd $OPTIONS -k start
ExecReload=/usr/sbin/httpd $OPTIONS -t
ExecReload=/bin/kill -HUP $MAINPID
ExecStop=/usr/sbin/httpd $OPTIONS -k stop
PrivateTmp=true

[Install]
WantedBy=multi-user.target 
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

(Yes it's a modified old httpd.service file, but it worked way better than the system installed one )
Comment 1 Luboš Uhliarik 2017-07-12 04:30:09 EDT
Hello,

you can find the commit here:

http://pkgs.fedoraproject.org/cgit/rpms/httpd.git/commit/?h=f24&id=86a94b34f9b9d8391bb2260171d7ca54b55c0f06

This was caused by merging rawhide(master) info f26/f25/f24. sysconfig file has been removed, as it is removed in rawhide/f26/f25.

In default httpd.service file, which is part of RPM, there is no EnvironmentFile directive. This means, you are using your customized .service file, which is causing problem with start of daemon.

I'm sorry, this unused file was cleaned by this branch merge, but it would come later anyway.
Comment 2 Joe Orton 2017-07-12 04:52:26 EDT
Since we've encouraged people to use that specific file in EnvironmentFile= in custom systemd overrides we should probably keep it, %ghost-ed, so it's not removed on updates.
Comment 3 Fedora Update System 2017-07-12 07:12:16 EDT
httpd-2.4.27-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4871efb056
Comment 4 Fedora Update System 2017-07-12 07:12:31 EDT
httpd-2.4.27-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-5f65279a9f
Comment 5 Fedora Update System 2017-07-12 07:12:43 EDT
httpd-2.4.27-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-9ded7c5670
Comment 6 Fedora Update System 2017-07-12 11:53:28 EDT
httpd-2.4.27-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4871efb056
Comment 7 Fedora Update System 2017-07-12 12:25:19 EDT
httpd-2.4.27-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-9ded7c5670
Comment 8 Fedora Update System 2017-07-12 14:22:44 EDT
httpd-2.4.27-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-5f65279a9f
Comment 9 Fedora Update System 2017-07-15 15:53:17 EDT
httpd-2.4.27-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Jay Guerette 2017-07-16 13:35:55 EDT
This update overwrote /etc/httpd/conf/httpd.conf, and I had to restore from backup.
Comment 11 Fedora Update System 2017-07-16 16:20:50 EDT
httpd-2.4.27-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Luboš Uhliarik 2017-07-17 06:08:26 EDT
(In reply to Jay Guerette from comment #10)
> This update overwrote /etc/httpd/conf/httpd.conf, and I had to restore from
> backup.

Hi Jay, 

I have just updated from 2.4.27-1.fc25 to 2.4.27-2.fc25 without having any issue. If you have a reproducer of described issue, please report it.
Comment 13 customercare 2017-07-17 06:31:49 EDT
no overwrite under fedora24
Comment 14 Fedora Update System 2017-07-17 09:28:11 EDT
httpd-2.4.27-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-38ae7e2b28
Comment 15 Fedora Update System 2017-07-17 17:20:14 EDT
httpd-2.4.27-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-38ae7e2b28
Comment 16 Jay Guerette 2017-07-19 15:07:24 EDT
I rolled back the update, and then applied it again, and didn't have the same problem. The fact that it happened is indisputable, the file was absolutely rolled back to the default. I can't reproduce the problem.
Comment 17 Fedora Update System 2017-07-23 17:51:41 EDT
httpd-2.4.27-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.