Bug 1469986 - Need enable catalog console in openshift-ansible
Need enable catalog console in openshift-ansible
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: ewolinet
Johnny Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-12 04:22 EDT by DeShuai Ma
Modified: 2017-08-16 15 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:31:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sdodson: needinfo-
sdodson: needinfo-
sdodson: needinfo-


Attachments (Terms of Use)

  None (edit)
Description DeShuai Ma 2017-07-12 04:22:36 EDT
Description of problem:
Now service-catalog and ansible-service-broker all support install by openshift-ansilbe. We need support catalog console in ocp36 too. As there is no card for this, just create the bug to trace the issue.

Version-Release number of the following components:

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:
Comment 1 Scott Dodson 2017-07-12 08:36:46 EDT
What's catalog console?
Comment 2 DeShuai Ma 2017-07-12 09:24:17 EDT
(In reply to Scott Dodson from comment #1)
> What's catalog console?

https://github.com/openshift/origin-web-catalog
Comment 3 Samuel Padgett 2017-07-12 10:02:02 EDT
The catalog UI needs to be enabled by a web console extension. (The right extension content depends on whether pod presets are enabled and the template broker is enabled.)

https://docs.openshift.org/latest/install_config/web_console_customization.html#web-console-enable-tech-preview-feature


For new catalog landing page:

window.OPENSHIFT_CONSTANTS.ENABLE_TECH_PREVIEW_FEATURE.service_catalog_landing_page = true;


If pod presets are enabled, you'll also need:

window.OPENSHIFT_CONSTANTS.ENABLE_TECH_PREVIEW_FEATURE.pod_presets = true;


If the template broker is enabled, you'll also need:

window.OPENSHIFT_CONSTANTS.ENABLE_TECH_PREVIEW_FEATURE.template_service_broker = true;
Comment 7 DeShuai Ma 2017-07-16 22:22:25 EDT
Could you help move to ON_QA, this should be fixed in latest puddle.
Comment 8 DeShuai Ma 2017-07-17 05:59:46 EDT
I try latest version, I find we also need PodPreset admission controller as default in /etc/origin/master/master-config.yaml Otherwise podpreset can't inject info to pod.

admissionConfig:
  pluginConfig:
    PodPreset:
      configuration:
        kind: DefaultAdmissionConfig
        apiVersion: v1
        disable: false

ref: https://github.com/openshift/origin/pull/14461#issuecomment-307807536
Comment 10 John Matthews 2017-07-17 11:02:54 EDT
I filed https://bugzilla.redhat.com/show_bug.cgi?id=1471881

Might be related to comment #8

When Creating a Binding a saw the below error from Service Catalog (puddle 3.6.152)

controller_binding.go:336] Creating Secret demo/postgresql-apb-399c3-t3idc
controller_binding.go:231] Error injecting binding results for Binding "demo/postgresql-apb-399c3-jmcmw": User "system:serviceaccount:kube-service-catalog:service-catalog-controller" cannot create podpresets.settings.k8s.io in project "demo"
Comment 11 DeShuai Ma 2017-07-18 01:33:11 EDT
Hi, John Matthews
This is different issue, you met the issue when create podpresets. For comment 8, this is after create podpresetsm then whether podpreset can inject pod not for create process.
Comment 12 DeShuai Ma 2017-07-18 01:34:13 EDT
As comment 8, we also add that.
Comment 14 Scott Dodson 2017-07-18 16:40:40 EDT
Additional changes merged.
Comment 15 Scott Dodson 2017-07-21 09:56:08 EDT
More changes merged.
Comment 16 DeShuai Ma 2017-07-24 02:53:57 EDT
Verify on openshift-ansible-3.6.162-1.git.0.50e29bd.el7.noarch.rpm. PodPreset admission controller is added.

admissionConfig:
  pluginConfig:
    PodPreset:
      configuration:
        apiVersion: v1
        disable: false
        kind: DefaultAdmissionConfig
Comment 17 Johnny Liu 2017-07-24 05:52:55 EDT
Also verify this bug with openshift-ansible-3.6.162-1.git.0.50e29bd.el7.noarch on a multiple master HA env, and PASS.


/etc/origin/master/openshift-ansible-catalog-console.js is created on each master in this cluster, and PodPreset admission controller is added into all the masters' config file.
Comment 19 errata-xmlrpc 2017-08-10 01:31:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.