Bug 1469989 - Support wildcard in dnf config-manager
Support wildcard in dnf config-manager
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
25
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-12 04:36 EDT by gaxweb
Modified: 2017-10-13 02:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-13 02:28:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gaxweb 2017-07-12 04:36:24 EDT
Description of problem:

You used to be able to do `yum-config-manager --disable rpmfusion*` to disable all repos that start with "rpmfusion". Now `dnf config-manager --set-disabled rpmfusion*` doesn't work.

Compare https://docs.fedoraproject.org/en-US/Fedora/17/html/System_Administrators_Guide/sec-Managing_Yum_Repositories.html with https://docs.fedoraproject.org/en-US/Fedora/26/html/System_Administrators_Guide/sec-Managing_DNF_Repositories.html to see for yourself.

Please add some sort of batch mechanism like that back in.
Comment 1 Jaroslav Rohel 2017-10-13 02:28:13 EDT
I tested config-manager command on my computer (I have dnf-0:2.7.2-1.git.61.4812d55.fc26.noarch).
I can't reproduce the problem. It is working.

But:
1. please use \ before globs or use '. Examples:
  dnf config-manager --set-disabled rpmfusion\*
  dnf config-manager --set-disabled 'rpmfusion*'

2. I see "docs-old" in documentation URL you use. Try another documentation. Eg. https://dnf-plugins-core.readthedocs.io/en/latest/config_manager.html 
In new documentation is description: 
<repo>
    Display / modify specified repository. If not specified display / modify main DNF configuration. Repositories can be specified using globs.

Note You need to log in before you can comment on or make changes to this bug.