Bug 1469991 - Pidgin is unable to connect to Yahoo account
Pidgin is unable to connect to Yahoo account
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pidgin (Show other bugs)
7.4
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Debarshi Ray
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-12 04:42 EDT by Michal Odehnal
Modified: 2017-07-25 02:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-25 02:28:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Odehnal 2017-07-12 04:42:00 EDT
Description of problem:
When I try to connect to Yahoo account via pidgin all I get is 'loading-icon' instead of available 'green' icon. Account is never reachable. 

Version-Release number of selected component (if applicable):
pidgin-2.10.11-5.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install Pidgin.
2. Have, or create, Yahoo account and add it via pidgin.
3. 

Actual results:
Loading icon shows next to the text 'Available'.

Expected results:
Green icon is displayed next to the text 'Available' and account is reachable, with contacts shown in pidgin table.

Additional info:
There is a so called 'workaround' in form of plugin: https://github.com/EionRobb/funyahoo-plusplus which shows in pidgin as Yahoo (2016), but this is not working either. I can see 'green' icon and it almost looks like it works, but after few seconds I get error message 'Session expired'. And again, account is not reachable.
Comment 3 Debarshi Ray 2017-07-13 09:15:46 EDT
I just happened to file bug 1470685 for dropping support for Yahoo!. :/

There is https://github.com/EionRobb/funyahoo-plusplus that implements Yahoo's new protocol, but I can't even find a Fedora package.
Comment 4 Michal Odehnal 2017-07-13 09:53:09 EDT
Thank you for linking the bug. I also tried the new protocol (as mentioned in Additional info in bug description). Followed all instructions to compile and install but to no success, Yahoo account is still not reachable, maybe I am doing something wrong in that case I hope you can advise me on better way to compile it and make it work.
Comment 5 Debarshi Ray 2017-07-13 12:09:30 EDT
(In reply to Michal Odehnal from comment #4)
> Followed all instructions to compile
> and install but to no success, Yahoo account is still not reachable, maybe I
> am doing something wrong in that case I hope you can advise me on better way
> to compile it and make it work.

I see. I haven't tried it myself. I will give it a shot and let you know.

However, even if it does work, it would be require the introduction of a separate new package, which is too late for RHEL 7.4, isn't it? So, I am afraid that in either case we may have to WONTFIX this particular bug. If the funyahoo-plusplus plugin works we could consider introducing it as a separate package in future.
Comment 6 Tomas Pelka 2017-07-25 02:28:52 EDT
Closing in favour of bz1470685.

Note You need to log in before you can comment on or make changes to this bug.