Bug 1469994 - Make output of openstack stack failures list overcloud easy to read
Make output of openstack stack failures list overcloud easy to read
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
high Severity high
: beta
: 12.0 (Pike)
Assigned To: Emilien Macchi
Marius Cornea
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-12 04:51 EDT by Marius Cornea
Modified: 2018-02-05 14:10 EST (History)
13 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-7.0.0-0.20170805163048.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-13 16:40:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 474269 None None None 2017-07-17 09:19 EDT
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-15 20:43:25 EST

  None (edit)
Description Marius Cornea 2017-07-12 04:51:54 EDT
Description of problem:

openstack stack failures list overcloud outputs the Ansible task output on a single line which makes it very difficult to read in order to debug the failure. 

Below is such an example:
http://paste.openstack.org/show/615126/

We should format the task failure output so it is easy to read by a human operator in order to quickly spot what went wrong. 

Version-Release number of selected component (if applicable):

puppet-tripleo-7.1.1-0.20170627224658.f99b72a.el7ost.noarch
openstack-tripleo-common-containers-7.2.1-0.20170628001837.5a6423b.el7ost.noarch
openstack-tripleo-heat-templates-7.0.0-0.20170628002128.el7ost.noarch
openstack-tripleo-image-elements-7.0.0-0.20170607161959.401d861.el7ost.noarch
python-tripleoclient-7.1.1-0.20170628001144.e4e66f7.el7ost.noarch
openstack-tripleo-common-7.2.1-0.20170628001837.5a6423b.el7ost.noarch
openstack-tripleo-validations-7.1.1-0.20170627224206.591a65f.el7ost.noarch
openstack-tripleo-ui-7.1.1-0.20170627161345.68e8684.el7ost.noarch
openstack-tripleo-puppet-elements-7.0.0-0.20170614005502.9285877.el7ost.noarch
Comment 1 Martin André 2017-07-17 09:19:21 EDT
Bogdan recently pushed a change upstream that should dramatically improve ansible logs readability: https://review.openstack.org/#/c/474269/
Comment 2 Omri Hochman 2017-07-19 09:30:04 EDT
(In reply to Martin André from comment #1)
> Bogdan recently pushed a change upstream that should dramatically improve
> ansible logs readability: https://review.openstack.org/#/c/474269/


According to Jarda -  If it's not in already by now , that would be RFE for osp13.  

Marius - Can you please retest with the patch ?
Comment 4 Dan Prince 2017-08-16 09:32:07 EDT
Re-reading the initial issue here this seems to be related to not liking the format of the Ansible output from the CLI. And not necessarily a containers specific issue. As such it is unclear to me that the patch Martin Andre linked in above would fix the issue.

Alex: Not convinced this one belongs to the containers DFG. Will wait for feedback from QE before re-assigning.
Comment 12 errata-xmlrpc 2017-12-13 16:40:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Note You need to log in before you can comment on or make changes to this bug.