Bug 1470031 - [Wayland] Alt modifier key is not handled on weston
Summary: [Wayland] Alt modifier key is not handled on weston
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1592493 (view as bug list)
Depends On:
Blocks: ffwayland
TreeView+ depends on / blocked
 
Reported: 2017-07-12 10:04 UTC by Hiroshi Hatake
Modified: 2018-06-22 08:17 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-22 08:17:39 UTC


Attachments (Terms of Use)

Description Hiroshi Hatake 2017-07-12 10:04:03 UTC
Description of problem:

When running firefox on weston, Alt modifier key is not handled.

Steps to Reproduce:

1. Launch Firefox
2. Visit some pages
3. Press Alt + ← or Alt + →

Actual results:

Latter reproducible step expects to fire "GoForward" or "GoBack" event, then moving visited pages which listed on history in current tab.

Expected results:

Nothing to do.

Additional info:

Firefox handles modifier keys by itself.
It depends on X11.
And when not existing X11, mModifierMasks is always set as 0.

 https://dxr.mozilla.org/mozilla-central/source/widget/gtk/nsGtkKeyUtils.cpp#197
https://dxr.mozilla.org/mozilla-central/source/widget/gtk/nsGtkKeyUtils.cpp#433

Used commands:

$ weston

And in another terminal,

$ WAYLAND_DISPLAY=wayland-1 GDK_BACKEND=wayland ./mach run

Comment 1 Hiroshi Hatake 2017-07-12 10:12:08 UTC
$ WAYLAND_DISPLAY=wayland-1 GDK_BACKEND=wayland firefox-wayland
is also usable to confirm this bug.

Comment 2 ashie@clear-code.com 2017-07-12 12:17:26 UTC
(In reply to Hiroshi Hatake from comment #0)
> Actual results:
> 
> Latter reproducible step expects to fire "GoForward" or "GoBack" event, then
> moving visited pages which listed on history in current tab.
> 
> Expected results:
> 
> Nothing to do.

Oops, "Actual results" and "Expected results" are reversed XD

Comment 3 Jan Kurik 2017-08-15 09:28:41 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.

Comment 4 Robert Mader 2017-12-08 14:31:33 UTC
I can confirm this running gnome-shell + firefox-wayland in flatpak from https://firefox-flatpak.mojefedora.cz/

Comment 5 Georg Müller 2018-06-01 10:24:34 UTC
Same on Fedora 28 with the latest firefox-wayland binary

Comment 6 Rodolfo Granata 2018-06-12 02:39:00 UTC
Same deal, is there a workaround?

Comment 7 ashie@clear-code.com 2018-06-13 13:56:23 UTC
I have a minimum patch for this issue:

https://github.com/webdino/meta-browser/blob/firefox-52esr/recipes-mozilla/firefox/firefox/wayland/gem/0001-Add-ad-hoc-solution-to-enable-Alt-modifier-on-Waylan.patch

I'll post it to bugzilla.mozilla.org.

Comment 8 ashie@clear-code.com 2018-06-14 02:46:09 UTC
(In reply to ashie@clear-code.com from comment #7)
> I'll post it to bugzilla.mozilla.org.

https://bugzilla.mozilla.org/show_bug.cgi?id=1468670

Comment 9 Fernando Herrera 2018-06-18 16:38:46 UTC
*** Bug 1592493 has been marked as a duplicate of this bug. ***

Comment 10 Martin Stransky 2018-06-22 08:17:39 UTC
Let's track it upstream.


Note You need to log in before you can comment on or make changes to this bug.