Bug 1470102 - firefox-54.0-2.fc27.x86_64 child windows cause crash
firefox-54.0-2.fc27.x86_64 child windows cause crash
Status: CLOSED DUPLICATE of bug 1472819
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-12 08:04 EDT by Jason Taylor
Modified: 2017-07-21 11:12 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-21 11:12:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
systemd-coredump log (32.58 KB, text/plain)
2017-07-12 08:13 EDT, Jason Taylor
no flags Details

  None (edit)
Description Jason Taylor 2017-07-12 08:04:36 EDT
Description of problem:
When a child window opens, for example the window that opens prompting a location to store a file being downloaded.


Version-Release number of selected component (if applicable):
firefox-54.0-2.fc27.x86_64

How reproducible:
Set downloads preferences to "Always ask you where to save files"
Attempt to download any file

Actual results:
Firefox immediately crashes as the child window is launched

Expected results:
select a download location and save the file

Additional info:
Jul 12 07:47:17 angrypenguin firefox.desktop[5677]: OKFailed to open curl lib from binary, use libcurl.so instead
Jul 12 07:47:13 angrypenguin firefox.desktop[5677]: ExceptionHandler::WaitForContinueSignal waiting for continue signal...
Jul 12 07:47:13 angrypenguin firefox.desktop[5677]: ExceptionHandler::SendContinueSignalToChild sent continue signal to child
Jul 12 07:47:13 angrypenguin firefox.desktop[5677]: ExceptionHandler::GenerateDump cloned child 5939
Comment 1 Jason Taylor 2017-07-12 08:13 EDT
Created attachment 1296936 [details]
systemd-coredump log
Comment 2 Steven Usdansky 2017-07-13 20:34:50 EDT
Same problem. Crash seems to occur only when prompting for a file name. Opening a print window does not cause FF to crash. However, print-to-file crashes FF. Downloading a file does not cause a crash if I save to my preset default location and don't try to rename the file.
Comment 3 Jan Horak 2017-07-21 11:12:52 EDT

*** This bug has been marked as a duplicate of bug 1472819 ***

Note You need to log in before you can comment on or make changes to this bug.