Bug 1470125 - Replica install fails to configure IPA-specific temporary files/directories
Replica install fails to configure IPA-specific temporary files/directories
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.4
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
ipa-qe
: Regression, ZStream
Depends On: 1469246
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-12 08:22 EDT by Jaroslav Reznik
Modified: 2017-08-01 07:29 EDT (History)
17 users (show)

See Also:
Fixed In Version: ipa-4.5.0-21.el7
Doc Type: Bug Fix
Doc Text:
Previously, when installing IdM replica, the installer incorrectly set the location and permissions of temporary directories. The IdM management framework requires these temporary directories to operate correctly. As a consequence, after rebooting the newly configured replica, the services tied to the management framework did not work and displayed non-specific error messages. To fix this bug, the installer now additionally adds a drop-in configuration file that re-creates the directory structure after rebooting. As a result, the IdM replica continues to work correctly after reboot.
Story Points: ---
Clone Of: 1469246
Environment:
Last Closed: 2017-08-01 07:29:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2017-07-12 08:22:23 EDT
This bug has been copied from bug #1469246 and has been proposed to be backported to 7.4 z-stream (EUS).
Comment 4 Mohammad Rizwan 2017-07-14 03:09:55 EDT
Verified using following steps:

1) Install Master
2) Install Replica
3) Reboot Replica
4) Access webUI on replica

version:

master:  ipa-server-4.5.0-21.el7.x86_64
         bind-9.9.4-51.el7.x86_64 

replica: ipa-server-4.5.0-21.el7.x86_64 
         bind-9.9.4-51.el7.x86_64

It is observed that before and after reboot of master/replica, webUI is accessible on both master/replica.

console output and screen shot is attached.
Comment 11 errata-xmlrpc 2017-08-01 07:29:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2327

Note You need to log in before you can comment on or make changes to this bug.