Bug 1470129 - Error trying to execute an ansible playbook through self_service portal “My Services->VM Instance->”
Error trying to execute an ansible playbook through self_service portal “My S...
Status: CLOSED DUPLICATE of bug 1460316
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: API (Show other bugs)
5.8.0
Unspecified Linux
unspecified Severity high
: GA
: cfme-future
Assigned To: Gregg Tanzillo
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-12 08:30 EDT by Sandeep Dhar
Modified: 2017-07-14 15:11 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-14 15:11:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of button (15.44 KB, image/png)
2017-07-12 08:30 EDT, Sandeep Dhar
no flags Details

  None (edit)
Description Sandeep Dhar 2017-07-12 08:30:37 EDT
Created attachment 1296943 [details]
screenshot of button

Description of problem: When user is logged to CFME (Compute->Infrastructure-> Virtual Machine) then they can run template for specific VM without any issue, but if they want to run the same in self_service portal then they  get error:
“Action not able to submit.”
 
Evm.log:
[----] E, [2017-07-10T09:54:51.445394 #5843:1782638] ERROR -- : <API> MIQ(Api::ServicesController.api_error) API Error
[----] E, [2017-07-10T09:54:51.445541 #5843:1782638] ERROR -- : <API> MIQ(Api::ServicesController.api_error) Api::BadRequestError: Unsupported Custom Action docker.yaml for the services resource specified


Version-Release number of selected component (if applicable):5.8.0


How reproducible:


Steps to Reproduce:
1. Create a button to execute an ansible playbook
2. Execute the playbook from the admin portal Compute->VMs->Button - It is successfull
3. Try to execute the same through the self_service portal - Error

Actual results: “Action not able to submit.”
 
Evm.log:
[----] E, [2017-07-10T09:54:51.445394 #5843:1782638] ERROR -- : <API> MIQ(Api::ServicesController.api_error) API Error
[----] E, [2017-07-10T09:54:51.445541 #5843:1782638] ERROR -- : <API> MIQ(Api::ServicesController.api_error) Api::BadRequestError: Unsupported Custom Action docker.yaml for the services resource specified


Expected results: Should execute successfully


Additional info:
Comment 5 Jillian Tullo 2017-07-14 15:11:01 EDT
Able to tell from the error message "for the service resource specified" that this is a duplicate of another bug. The SUI should have been making the call to /api/vms instead of /api/services.

*** This bug has been marked as a duplicate of bug 1460316 ***

Note You need to log in before you can comment on or make changes to this bug.