Bug 1470165 - NO_PROXY was missed in /etc/sysconfig/docker
NO_PROXY was missed in /etc/sysconfig/docker
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Tim Bielawa
Gan Huang
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-12 09:27 EDT by Gan Huang
Modified: 2017-08-16 15 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: A fix for a separate PROXY related issue was merged Consequence: Various proxy related operations began to fail Fix: A correct fix for the original PROXY related issue was merged Result: Functionality restored
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:31:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gan Huang 2017-07-12 09:27:23 EDT
Description of problem:
Trigger containerized installation with http_proxy/https_proxy settings, it resulted in that there was no no_proxy variable set in /etc/sysconfig/docker.

Version-Release number of the following components:
openshift-ansible-3.6.140-1.git.0.4a02427.el7.noarch.rpmn

How reproducible:
always

Steps to Reproduce:
1. Trigger containerized installation with http_proxy/https_proxy settings


Actual results:
NO_PROXY missed in /etc/sysconfig/docker
# grep "PROXY" /etc/sysconfig/docker
HTTP_PROXY='http://xxx.redhat.com:3128'
HTTPS_PROXY='http://xxx.redhat.com:3128'

Expected results:
NO_PROXY set correctly in /etc/sysconfig/docker

Additional info:
Comment 4 Tim Bielawa 2017-07-13 22:14:33 EDT
Can you verify the permutations we have here in this gist are correct? We tried to match the upstream documentation as best we could with what we think the expected results should be from using them:

https://gist.github.com/tbielawa/ab98b0ba45742c573e551298dee36918

Per docs in: https://docs.openshift.org/latest/install_config/install/advanced_install.html#advanced-install-configuring-global-proxy

Thanks!
Comment 5 Gan Huang 2017-07-14 02:51:24 EDT
(In reply to Tim Bielawa from comment #4)

> https://gist.github.com/tbielawa/ab98b0ba45742c573e551298dee36918

(Seems the Raw format is more readable :) )

If nothing proxy variables specified, is there a reason to set `NO_PROXY`? (Anyway I don't object to this setting as I don't think it would get something hurt)

The rest looks good to me if they're for Docker configurations.

For masters/nodes/builddefaults proxy settings, we should add `openshift_master_portal_net` and `osm_cluster_network_cidr` as defaults in NO_PROXY. (We don't add it to Docker configurations as Docker doesn't support CIDRs)
Comment 8 Tim Bielawa 2017-07-17 10:43:13 EDT
Working on this again in https://github.com/openshift/openshift-ansible/pull/4762
Comment 11 Gan Huang 2017-07-25 05:55:22 EDT
Verified with openshift-ansible-3.6.170-1.git.0.aef02f6.el7.noarch.rpm
Comment 13 errata-xmlrpc 2017-08-10 01:31:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.