Bug 147019 - DocBook XML Filter General Input/Output Error
DocBook XML Filter General Input/Output Error
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-03 13:27 EST by Pasha Minallah
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 1.9.89-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-05 13:20:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pasha Minallah 2005-02-03 13:27:44 EST
Description of problem:

DocBook XML Filters don't work!  They used to work in the previous release of
openoffice.org.

When importing (or exporting) the following errors are encountered.

Error loading (or saving) document ${document.name}:
General Error.
General input/output error.

Version-Release number of selected component (if applicable):

1.1.3-2.5.fc3

How reproducible:

Steps to Reproduce:

1. Download the DocBook XML Filter from
http://xml.openoffice.org/xmerge/downloads/DocBookFilter.zip.  Unzip in either
program or user folder for OOo.
2. Add either article or chapter filter by following instructions from
http://xml.openoffice.org/xmerge/docbook/.

Note that the stylesheets on the website need to be swapped:
# For XSLT for Export browse to the chapter export stylesheet
(sofftodocbookheadings_chapter.xsl).
# For XSLT for Import browse to the chapter import stylesheet
(docbooktosoffheadings.xsl).

3. Attempt to save a simple OpenOffice.org document or to open a valid DocBook
XML file using the DocBook Filter.

Actual results:

Error loading (or saving) document ${document.name}:
General Error.
General input/output error.

Expected results:

An OpenOffice.org document is expected to save without errors and a valid
DocBook XML file is expected to open without errors.

Additional info:
Comment 1 Pasha Minallah 2005-02-03 20:00:02 EST
I downloaded OpenOffice.org version 1.1.4 today and tested the DocBook
Filters shipped with it.  I also tested these same filters with the
Fedora Core 3 OOo package and found that the difference between its
behavior and that of the FC3 package is that the one from OOo
successfully exports but fails in importing whereas the FC3 package
fails on both import and export.
Comment 2 Dan Williams 2005-02-22 10:01:00 EST
I _believe_ that the docbook filters use Java in some way, which Fedora cannot
use or build OOo with.  The XSLT filters are actually written in Java and
therefore we don't build them.  We should not be shipping the UI for this filter
however, which should take care of this problem.

Note that we are working on making OOo 2.0 compile with a free Java
implementation (gcj), so many of these types of "no Java so it doesn't work"
bugs will be fixed there.

(BTW, are you saying that it this filter worked when using previous
_RedHat_/_Fedora_ versions of OOo?  Or are you saying that it worked in previous
versions you downloaded from OpenOffice.org's website?)
Comment 3 Caolan McNamara 2005-04-05 13:20:35 EDT
There is no minimal support of libgcj as a java replacement in 1.9.89-3. Your
milage may vary as libgcj matures, but in theory java components can run under
rawhide OOo.

Note You need to log in before you can comment on or make changes to this bug.