Bug 1470191 - ODL Logging configuration needs to be optimized
ODL Logging configuration needs to be optimized
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-opendaylight (Show other bugs)
11.0 (Ocata)
Unspecified Unspecified
medium Severity medium
: beta
: 12.0 (Pike)
Assigned To: Janki
Itzik Brown
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-12 09:50 EDT by Tim Rozet
Modified: 2018-02-05 14:10 EST (History)
10 users (show)

See Also:
Fixed In Version: puppet-opendaylight-4.1.0-0.20170728021921.3768d5e.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-13 16:40:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenDaylight Bug 8854 None None None 2017-07-13 11:07 EDT
OpenDaylight gerrit 60294 None None None 2017-07-13 11:08 EDT
OpenDaylight gerrit 60602 None None None 2017-07-26 06:18 EDT

  None (edit)
Description Tim Rozet 2017-07-12 09:50:53 EDT
Description of problem:
Right now we configure ODL logging to use 10 karaf files which rotate after one is full.  The size is also too small in comparison to the amount of logging ODL produces.  We should modify the configuration to use a single file and have a very large file limit.  Ideally we want ODL logging to be part of systemd journaling.
Comment 1 Sam Hague 2017-07-12 10:07:35 EDT
We should configure the logging to use a single large file. [1] is the link to the shell script in the upstream job for configuring a single large file. The script sets the size to 30GB but in normal practice it is less than 50MB.

The final config would look like:

modify file: org.ops4j.pax.logging.cfg

log4j.appender.out.maxBackupIndex=1
log4j.appender.out.maxFileSize=30GB

[1] https://github.com/opendaylight/releng-builder/blob/master/jjb/integration/include-raw-integration-configure-clustering.sh#L80
Comment 2 Janki 2017-07-26 06:18:54 EDT
Upstream pacthes cherry-picked for Carbon:
https://git.opendaylight.org/gerrit/#/c/60759/
Comment 7 Michael Vorburger 2017-07-27 12:42:17 EDT
> Ideally we want ODL logging to be part of systemd journaling

==> Bug 1475951 ...
Comment 8 Janki 2017-07-28 01:17:57 EDT
Cherry-pick to stable carbon https://git.opendaylight.org/gerrit/#/c/60816/
Comment 11 Janki 2017-08-16 10:12:06 EDT
With this change, there would be 2 files generated of size 10 GB each.
Comment 12 Itzik Brown 2017-08-21 07:00:08 EDT
Verified with opendaylight-6.1.0-2.el7ost.noarch
Comment 15 errata-xmlrpc 2017-12-13 16:40:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Note You need to log in before you can comment on or make changes to this bug.