Bug 1470196 - mariadb library upgrade to 10.2 causes perl-DBD-MySQL FTBFS
mariadb library upgrade to 10.2 causes perl-DBD-MySQL FTBFS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-DBD-MySQL (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jitka Plesnikova
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks: 1467297
  Show dependency treegraph
 
Reported: 2017-07-12 09:59 EDT by Honza Horak
Modified: 2017-07-14 08:47 EDT (History)
4 users (show)

See Also:
Fixed In Version: perl-DBD-MySQL-4.043-2.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-14 08:46:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (1.33 KB, patch)
2017-07-12 09:59 EDT, Honza Horak
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 122429 None None None 2017-07-14 08:46 EDT
CPAN 122431 None None None 2017-07-14 08:47 EDT
Github perl5-dbi/DBD-mysql/issues/139 None None None 2017-07-14 02:17 EDT
Github perl5-dbi/DBD-mysql/pull/133 None None None 2017-07-14 02:16 EDT

  None (edit)
Description Honza Horak 2017-07-12 09:59:05 EDT
Created attachment 1297022 [details]
Proposed patch

Description of problem:
With new version of MariaDB 10.2 we see basically this two separate issues:

dbdimp.c: In function 'mysql_dr_connect':
dbdimp.c:2000:13: error: 'MYSQL {aka struct st_mysql}' has no member named 'reconnect'
       result->reconnect=0;
             ^~

dbdimp.c: In function 'mysql_st_prepare':
dbdimp.c:2779:19: error: 'MYSQL_VERSION_ID' undeclared (first use in this function); did you mean 'MYSQL_VERSION_5_0'?
                   MYSQL_VERSION_ID, statement);
                   ^~~~~~~~~~~~~~~~
                   MYSQL_VERSION_5_0
dbdimp.c:2779:19: note: each undeclared identifier is reported only once for each function it appears in

The attached patch should fix the FTBFS issue.
Comment 1 Adam Williamson 2017-07-13 22:16:34 EDT
There seems to be a rather complex debate going on about a PR to fix the MariaDB compatibility (while not losing MySQL compatibility) upstream:

https://github.com/perl5-dbi/DBD-mysql/pull/133

Any thoughts on that? They seem to have identified some further issues, but you might have a better handle on the versioning bits than they do...

Note You need to log in before you can comment on or make changes to this bug.