Bug 1470282 - [RFE] create an OVS bridge with an IP-carrying port on top of another connection [NEEDINFO]
[RFE] create an OVS bridge with an IP-carrying port on top of another connection
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager (Show other bugs)
7.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Lubomir Rintel
Desktop QE
Marc Muehlfeld
: FutureFeature
Depends On:
Blocks: 1477926 1470965 1491326
  Show dependency treegraph
 
Reported: 2017-07-12 12:04 EDT by Dan Kenigsberg
Modified: 2018-04-10 09:28 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1491326 (view as bug list)
Environment:
Last Closed: 2018-04-10 09:27:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
igkioka: needinfo? (lrintel)
mmuehlfe: needinfo? (lrintel)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0778 None None None 2018-04-10 09:28 EDT

  None (edit)
Description Dan Kenigsberg 2017-07-12 12:04:31 EDT
Description of problem:
OVN uses an OpenVSwitch bridge named br-int to connect its ports and do its have all its smart openflow rules. br-int is created and soly controlled by OVN. br-int can delegate its outgoing traffic either to a tunnel device, or to a simple-stupid OpenVSwitch bridge, e.g. brbond0, connected to a bonding device.

The administrator of the host is responsible to create the latter bridge and connect it to the proper interface.

In this RFE I am asking to let NM define such an interface. Just like NM is able to create a Linux bridge and connect it to an underlying connection, it should do the same for an OVS bridge.

Just like it can set an IP address on a Linux bridge, I'm requesting to create a port on a the OVS bridge, and configure the address there.

RHV does the latter on itself, but I believe that it would be better to implement this once, on the platform level.

Note that unlike Linux bond, OVS does not need to be connected through a vlan device in order to tag all outgoing traffic. A better implementation would be to vlan-tag the underlying interface within the OVS bridge.
Comment 6 Vladimir Benes 2017-12-14 09:27:38 EST
This should work but it doesn't:
nmcli conn add conn.type ovs-bridge conn.interface bridge0
nmcli conn add conn.type ovs-port conn.interface port1 conn.master bridge0
nmcli conn add type ethernet conn.interface eth2 conn.master port1 slave-type ovs-port

it works with dummy device:
nmcli conn add conn.type ovs-bridge conn.interface bridge0
nmcli conn add conn.type ovs-port conn.interface port1 conn.master bridge0
nmcli conn add type dummy conn.interface dummy0 conn.master port1 slave-type ovs-port
Comment 7 Vladimir Benes 2018-01-19 08:55:10 EST
moving back to ON_QA as it looks blocking bug is fixed: bug 1519179
Comment 8 Vladimir Benes 2018-01-31 11:06:47 EST
few bugs filed but generally working well, automated and running in CI.
Comment 11 errata-xmlrpc 2018-04-10 09:27:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0778

Note You need to log in before you can comment on or make changes to this bug.