Bug 1470286 - Missing python-sphinx dependency
Missing python-sphinx dependency
Status: CLOSED UPSTREAM
Product: RDO
Classification: Community
Component: distribution (Show other bugs)
trunk
x86_64 Linux
unspecified Severity medium
: ---
: trunk
Assigned To: David Moreau Simard
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-12 12:09 EDT by Dimitri Savineau
Modified: 2017-08-11 09:21 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-11 09:21:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 483996 None None None 2017-07-14 16:34 EDT

  None (edit)
Description Dimitri Savineau 2017-07-12 12:09:07 EDT
Description of problem:

Since the OSP12 puddle 2017-07-11.7 the openstack-rally package doesn't have dependency on python-sphinx.
It has been remove upstream [1] but the current code seems to still use it.
The rally commands exit with a python trace because the sphinx python module is missing (and not present in the puddle anymore).

Version-Release number of selected component (if applicable):

OSP12 puddle 2017-07-11.7
openstack-rally-0.9.1-0.20170703215956.d32b2d5.el7ost.1.noarch
also tested on the package coming from the latest puddle (2017-07-12.3)
openstack-rally-0.9.1-0.20170707094646.caa9fc0.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install openstack-rally package
2. Run rally command

Actual results:
$ rally-manage db create
Traceback (most recent call last):
  File "/usr/bin/rally-manage", line 6, in <module>
    from rally.cli.manage import main
  File "/usr/lib/python2.7/site-packages/rally/cli/manage.py", line 23, in <module>
    from rally.cli import cliutils
  File "/usr/lib/python2.7/site-packages/rally/cli/cliutils.py", line 34, in <module>
    from rally import api
  File "/usr/lib/python2.7/site-packages/rally/api.py", line 30, in <module>
    from rally.common import opts
  File "/usr/lib/python2.7/site-packages/rally/common/opts.py", line 20, in <module>
    from rally import osclients
  File "/usr/lib/python2.7/site-packages/rally/osclients.py", line 25, in <module>
    from rally.common.plugin import plugin
  File "/usr/lib/python2.7/site-packages/rally/common/plugin/plugin.py", line 21, in <module>
    from rally.common.plugin import info
  File "/usr/lib/python2.7/site-packages/rally/common/plugin/info.py", line 18, in <module>
    from sphinx.util import docstrings
ImportError: No module named sphinx.util

Additional info:
[1] https://review.rdoproject.org/r/#/c/7573/
Comment 1 David Moreau Simard 2017-07-14 11:25:36 EDT
Reverted in https://review.rdoproject.org/r/#/c/7686/
Comment 2 Alan Pevec 2017-07-14 12:48:50 EDT
> from sphinx.util import docstrings

Can someone please talk to upstream? They can't seriously requires Sphinx at runtime.
Comment 3 David Moreau Simard 2017-07-14 12:50:18 EDT
@Alan I believe jschlueter and chandankumar are trying to figure out how to take the dependency out upstream.
Comment 4 Dimitri Savineau 2017-08-11 09:14:49 EDT
I guess we can change the status of this bug since the problem has been resolved upstream ?
Comment 5 David Moreau Simard 2017-08-11 09:21:35 EDT
Yes.

Note You need to log in before you can comment on or make changes to this bug.