Bug 1470300 - If eclipse-nls-* packages are installed eclipse fails to start
If eclipse-nls-* packages are installed eclipse fails to start
Status: NEW
Product: Fedora
Classification: Fedora
Component: eclipse-nls (Show other bugs)
26
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Sean Flanigan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-12 12:54 EDT by Enrique
Modified: 2017-07-12 12:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/home/user/workspace/.metadata/.log (260.46 KB, text/plain)
2017-07-12 12:54 EDT, Enrique
no flags Details

  None (edit)
Description Enrique 2017-07-12 12:54:49 EDT
Created attachment 1297127 [details]
/home/user/workspace/.metadata/.log

Description of problem:

 After upgrading to Fedora 26, eclipse is unable to start. After selecting the workspace a window appears with the following message;
"An error has occurred, See the log file
/home/user/workspace/.metadata/.log". I have attached that log file here

Version-Release number of selected component (if applicable):

# rpm -qa | grep eclipse
eclipse-p2-discovery-4.6.3-3.fc26.noarch
eclipse-linuxtools-5.3.1-2.fc26.noarch
eclipse-swt-4.6.3-3.fc26.x86_64
eclipse-gcov-5.3.1-2.fc26.noarch
eclipse-cdt-arduino-9.2.1-2.fc26.x86_64
eclipse-mylyn-tasks-bugzilla-3.21.0-4.fc26.noarch
eclipse-usage-4.4.3-1.fc26.noarch
eclipse-rpm-editor-5.3.1-2.fc26.noarch
eclipse-perf-5.3.1-2.fc26.noarch
eclipse-cdt-parsers-9.2.1-2.fc26.x86_64
eclipse-mylyn-builds-3.21.0-4.fc26.noarch
eclipse-ecf-core-3.13.3-2.fc26.x86_64
eclipse-nls-de-4.6.0-2.fc26.noarch
eclipse-e4-importer-0.2.0-0.3.gitb33919c.fc26.noarch
eclipse-emf-runtime-2.12.0-4.fc26.noarch
eclipse-contributor-tools-4.6.3-3.fc26.x86_64
eclipse-emf-core-2.12.0-4.fc26.x86_64
eclipse-valgrind-5.3.1-2.fc26.noarch
eclipse-cdt-docker-9.2.1-2.fc26.x86_64
eclipse-dtp-1.12.0-9.fc26.noarch
eclipse-platform-4.6.3-3.fc26.x86_64
eclipse-ptp-9.1.2-1.fc26.x86_64
eclipse-mylyn-versions-3.21.0-4.fc26.noarch
eclipse-abrt-0.0.3-2.fc26.noarch
eclipse-epp-logging-2.0.3-3.fc26.noarch
eclipse-packagekit-0.2.0-5.fc26.noarch
eclipse-mylyn-3.21.0-4.fc26.noarch
eclipse-tm-terminal-4.2.0-1.fc26.noarch
eclipse-nls-it-4.6.0-2.fc26.noarch
eclipse-subclipse-4.2.2-2.fc26.noarch
eclipse-swtbot-2.5.0-5.fc26.noarch
eclipse-cdt-native-9.2.1-2.fc26.x86_64
eclipse-pde-4.6.3-3.fc26.x86_64
eclipse-mylyn-context-java-3.21.0-4.fc26.noarch
eclipse-pydev-5.5.0-3.fc26.x86_64
eclipse-nls-fr-4.6.0-2.fc26.noarch
eclipse-mylyn-context-cdt-3.21.0-4.fc26.noarch
eclipse-gef-3.11.0-2.fc26.noarch
eclipse-equinox-osgi-4.6.3-3.fc26.x86_64
eclipse-linuxtools-libhover-5.3.1-2.fc26.noarch
eclipse-ecf-runtime-3.13.3-2.fc26.noarch
eclipse-launchbar-2.1.0-2.fc26.noarch
eclipse-egit-4.7.0-2.fc26.noarch
eclipse-fedorapackager-0.6.0-2.fc26.noarch
eclipse-cdt-llvm-9.2.1-2.fc26.x86_64
eclipse-nls-4.6.0-2.fc26.noarch
eclipse-changelog-5.3.1-2.fc26.noarch
eclipse-filesystem-1.0-8.fc26.x86_64
eclipse-gprof-5.3.1-2.fc26.noarch
eclipse-mylyn-docs-wikitext-3.21.0-4.fc26.noarch
eclipse-pydev-mylyn-5.5.0-3.fc26.x86_64
eclipse-mylyn-tasks-web-3.21.0-4.fc26.noarch
eclipse-remote-2.1.1-2.fc26.noarch
eclipse-cdt-qt-9.2.1-2.fc26.x86_64
eclipse-mylyn-tasks-trac-3.21.0-4.fc26.noarch
eclipse-linuxtools-docker-5.3.1-2.fc26.noarch
eclipse-linuxtools-vagrant-5.3.1-2.fc26.noarch
eclipse-nls-es-4.6.0-2.fc26.noarch
eclipse-cdt-tests-9.2.1-2.fc26.x86_64
eclipse-tm-terminal-connectors-4.2.0-1.fc26.noarch
eclipse-mylyn-builds-hudson-3.21.0-4.fc26.noarch
eclipse-cdt-9.2.1-2.fc26.x86_64
eclipse-rse-3.7.2-2.fc26.noarch
eclipse-mpc-1.5.4-1.fc26.noarch
eclipse-tests-4.6.3-3.fc26.x86_64
eclipse-oprofile-5.3.1-2.fc26.noarch
eclipse-jgit-4.7.0-7.fc26.noarch
eclipse-jdt-4.6.3-3.fc26.noarch

How reproducible:

Always

Steps to Reproduce:
1. Start eclipse in the command line
2. Select a workspace. In my case the workspace has been inherited from the Fedora 25 installation.

Actual results:

 A pop-up window appears with an error


Additional info:

 As a workaround, removing the nls packages allows to start eclipse:
# dnf remove eclipse-nls-fr.noarch eclipse-nls-es.noarch eclipse-nls-de.noarch

Note You need to log in before you can comment on or make changes to this bug.