Bug 1470340 - gdm restarts X without waiting for previous generation to terminate
gdm restarts X without waiting for previous generation to terminate
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gdm (Show other bugs)
7.4
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
: Regression, ZStream
Depends On: 1469755
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-12 14:45 EDT by Tom Lavigne
Modified: 2017-08-01 07:29 EDT (History)
11 users (show)

See Also:
Fixed In Version: gdm-3.22.3-12.el7
Doc Type: Bug Fix
Doc Text:
Previously, due to a race condition in logout handling, the GNOME Display Manager (GDM) in some cases started one X server while another was shutting down. Consequently, the second X server failed to start. With this update, GDM waits for the first X server to fully quit before GDM starts the second X server, which prevents the described problem from occurring.
Story Points: ---
Clone Of: 1469755
Environment:
Last Closed: 2017-08-01 07:29:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Lavigne 2017-07-12 14:45:48 EDT
This bug has been copied from bug #1469755 and has been proposed
to be backported to 7.4 z-stream (EUS).
Comment 6 Michael Boisvert 2017-07-18 10:19:49 EDT
Joseph, did you mean to switch this from VERIFIED to ON_QA?
Comment 7 Joseph Kachuck 2017-07-18 13:26:39 EDT
Hello Michael,
No would you be able to switch it to verified?

Thank You
Joe Kachuck
Comment 8 Michael Boisvert 2017-07-18 14:27:11 EDT
(In reply to Joseph Kachuck from comment #7)
> Hello Michael,
> No would you be able to switch it to verified?
> 
> Thank You
> Joe Kachuck

Not a problem. I assumed it was a mid air collision based on the time stamps.
Comment 9 errata-xmlrpc 2017-08-01 07:29:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2328

Note You need to log in before you can comment on or make changes to this bug.