Bug 147037 - 32-bit pthread_cancel causes kernel panic
32-bit pthread_cancel causes kernel panic
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-02-03 16:30 EST by Timur Tabi
Modified: 2015-01-04 17:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-07 20:33:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Test program that demonstrates the bug. (533 bytes, text/plain)
2005-02-03 16:32 EST, Timur Tabi
no flags Details
Kernel panic message (1.94 KB, text/plain)
2005-02-03 16:35 EST, Timur Tabi
no flags Details

  None (edit)
Description Timur Tabi 2005-02-03 16:30:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2)

Description of problem:
When calling pthread_cancel in a 32-bit app, the kernel panics.  This
doesn't happen if you call it from a 64-bit app, and it only happens
on FC1, not FC2 or FC3 or any other kernel or distro that we've tried.

I've attached a test program, and the kernel panic message.  The test
program can be compiled with "gcc -m32 pthread_test.c -o pthread_test
-lpthread".  However, you need to install the following RPMs first:


Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install necessary RPMs
2. Compile test program
3. Run test program.

Additional info:

I understand that FC1 is deprecated, but I want to open the bug
anyway.  We have customers using FC1 that are impacted by this bug,
and so it needs to be reported, even if it will not get fixed.  Or
perhaps there is a fix available that I just don't know about.
Comment 1 Timur Tabi 2005-02-03 16:32:20 EST
Created attachment 110625 [details]
Test program that demonstrates the bug.

Compile with "gcc -m32 pthread_test.c -o pthread_test -lpthread".
Comment 2 Timur Tabi 2005-02-03 16:35:15 EST
Created attachment 110626 [details]
Kernel panic message
Comment 3 Timur Tabi 2005-02-03 16:50:45 EST
FYI, I installed kernel-smp-2.4.22-1.2199.nptl.x86_64.rpm and it has
not fixed the problem.  I don't think any other RPM in
is applicable, so that's the only one I tried.
Comment 4 Jakub Jelinek 2005-02-06 15:54:31 EST
Kernel panic is surely a kernel bug, not glibc.
Comment 5 Dave Jones 2005-02-07 20:33:16 EST
FC1 end of lifed long ago..

Note You need to log in before you can comment on or make changes to this bug.