Bug 147046 - NetworkManager and iptables prevent system from shutdown
NetworkManager and iptables prevent system from shutdown
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-03 17:51 EST by Quereller
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-20 12:53:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
chkconfig --list (3.45 KB, text/plain)
2005-02-03 17:54 EST, Quereller
no flags Details

  None (edit)
Description Quereller 2005-02-03 17:51:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
When running services iptables and NetworkManger together, system
hangs on shutdown when stopping iptables. It even hangs when I remove
K92iptables so it could also be related to stoping loopback.

Version-Release number of selected component (if applicable):
NetworkManager-0.3.3-1.cvs20050119.2.fc3 iptables-1.2.11-3.1.FC3
kernel-2.6.10-1.760_FC3 

How reproducible:
Always

Steps to Reproduce:
1. Start NetworkManger
2. Start iptables
3. shutdown

Actual Results:  system hangs

Expected Results:  clean shutdown

Additional info:

Hardware: 1 NIC e1000

The problem is not related to the iptables rules itself, you can
accept all packets and it happens anyway
Comment 1 Quereller 2005-02-03 17:54:50 EST
Created attachment 110630 [details]
chkconfig --list
Comment 2 Mark Stier 2005-03-19 18:12:33 EST
This bug occurs on my notebook, too. I have done some investigation and can
provide a quick work-around:

disable the iptables modules unloading by setting the corresponding option in
/etc/sysconfig/iptables-config to "no".

Shutting down the iptables service lets me reproduce the problem: I had a
"modprobe -r ipt_state" process consuming all CPU and which could not be killed
by a KILL signal.

The bug only occurs if the NetworkManager actually has been active (i.e. after
the NetworkManagerInfo applet told it where to connect).

Note You need to log in before you can comment on or make changes to this bug.