Bug 1470490 - Service provision on Azure fails when managed image is used.
Service provision on Azure fails when managed image is used.
Status: CLOSED DUPLICATE of bug 1470491
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning (Show other bugs)
5.8.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: cfme-future
Assigned To: Greg McCullough
Dave Johnson
provider:azure:provision
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-13 00:00 EDT by Jeff Teehan
Modified: 2017-12-05 10:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-13 11:07:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Teehan 2017-07-13 00:00:05 EDT
Description of problem:
There is a problem, on with Orchestration, when provisioning using a Managed Image from Azure.

Version-Release number of selected component (if applicable):
5.8.1.x (It's in 5.7.3 as well, but I'll add another bug)

How reproducible:
Alwalys

Steps to Reproduce:
1.  Create managed image on Azure
2.  Create a catalog item type=Orchestration using the azure provider.
3.  Service Catalog provision and fill in all fields.  Select a Managed image for image.

Actual results:
5.7.3 fails with "The value of parameter bootDiagnostics.storageAccountUri is invalid."
5.8.1 fails with "Server [EVM] Service [AzureOneVM-20170712-234801] Step [checkprovisioned] Status [Error Creating Stack] Message [Creating Stack]"
Expected results:


Additional info:
If you LifeCycle provision the same image it works correctly.
I leave appliance 5.7.3 running on 10.16.6.204, 5.8.1 is running on 10.8.198.175
Comment 2 Greg McCullough 2017-07-13 11:07:45 EDT
This BZ was opened for version 5.8, but both versions (5.7/5.8) should be handled from a single BZ and once resolved will be back-ported where required.  The BZ will be cloned during back-porting.

*** This bug has been marked as a duplicate of bug 1470491 ***

Note You need to log in before you can comment on or make changes to this bug.