Bug 1470498 - gluster block provisioner fails to create block device
gluster block provisioner fails to create block device
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhgs-gluster-block-prov-container (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Mohamed Ashiq
krishnaram Karthick
:
Depends On:
Blocks: 1445448
  Show dependency treegraph
 
Reported: 2017-07-13 00:39 EDT by krishnaram Karthick
Modified: 2017-07-13 01:26 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-13 00:48:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description krishnaram Karthick 2017-07-13 00:39:03 EDT
Description of problem:

When a claim request is submitted to create a gluster block device, provisioning fails.
Dynamic provisioning however works for a regular gluster volume.

Events:
  FirstSeen     LastSeen        Count   From                                                            SubObjectPath   Type            Reason                  Message
  ---------     --------        -----   ----                                                            -------------   --------        ------                  -------
  14m           3m              187     persistentvolume-controller                                                     Normal          ExternalProvisioning    cannot find provisioner "gluster.org/glusterblock", expecting that a volume for the claim is provisioned either manually or via external software
  14m           1m              13      gluster.org/glusterblock 9e694b9a-677c-11e7-a183-0a580a830034                   Normal          Provisioning            External provisioner is provisioning volume for claim "storage-project/claimheketi"
  13m           1m              13      gluster.org/glusterblock 9e694b9a-677c-11e7-a183-0a580a830034                   Warning         ProvisioningFailed      Failed to provision volume with StorageClass "glusterblock": glusterblock: failed to create volume: [heketi] error creating volume Post http://172.30.175.11:8080/blockvolumes: dial tcp 172.30.175.11:8080: getsockopt: no route to host

Version-Release number of selected component (if applicable):
rhgs3/rhgs-gluster-block-prov-docker:3.3.0-5
cns-deploy-5.0.0-8.el7rhgs.x86_64

How reproducible:
Always

Steps to Reproduce:
create a claim file & try to submit a claim request to create a block volume

Actual results:
gluster block volume creation failed

Expected results:
gluster block volume should be created

Additional info:
heketi logs shall be attached
Comment 2 krishnaram Karthick 2017-07-13 00:48:40 EDT
This issue is due to a mis-configuration of claim file. Resturl was not updated with latest svc details.

kind: StorageClass
apiVersion: storage.k8s.io/v1
metadata:
  name: glusterblock
provisioner: gluster.org/glusterblock
parameters:
    resturl: "http://172.30.175.11:8080"
    #restuser: "admin"
    #restsecretnamespace: "default"
    #restsecretname: "heketi-secret2"
    opmode: "heketi"
    #hacount: "1"
    chapauth: "true"
    #clusterids: "454811fcedbec6316bc10e591a57b472"

Note You need to log in before you can comment on or make changes to this bug.