Bug 1470525 - 'uuidd' daemon should auto-start with system but does not
'uuidd' daemon should auto-start with system but does not
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: util-linux (Show other bugs)
7.3
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Karel Zak
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-13 02:13 EDT by sdarade
Modified: 2017-07-14 04:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-14 04:28:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sdarade 2017-07-13 02:13:06 EDT
Description of problem:

uuidd daemon should auto-start with system but does not

Version-Release number of selected component (if applicable): 

uuidd-2.23.2-33.el7_3.2.x86_64


How reproducible:


Steps to Reproduce:
1.Install uuidd-2.23.2-33.el7_3.2.x86_64
2.system enable uuidd
3.system start uuidd

Actual results:

Does NOT auto-start with reboot

Expected results:

Should auto-start with reboot

Additional info:


Workaround:

Add following in /usr/lib/systemd/system/uuidd.service

[Install]
WantedBy=multi-user.target
Comment 2 Michal Hlavinka 2017-07-13 04:16:36 EDT
uuidd comes from uuidd package (created from util-linux srpm), not uuid package. reassigning
Comment 3 Karel Zak 2017-07-14 04:21:42 EDT
The service uses socket-activation. It does not have to run, it's started by systemd on demand (when libbuuid ask for time based UUID, e.g. "uuidgen -t"). The important is socket in this case, see:

# systemctl status uuidd.socket
● uuidd.socket - UUID daemon activation socket
   Loaded: loaded (/usr/lib/systemd/system/uuidd.socket; enabled; vendor preset: enabled)
   Active: active (listening) since Fri 2017-07-14 10:19:35 CEST; 1s ago
   Listen: /var/uuidd/request (Stream)

(this is from fedora)

If you want to be really sure that all works as expected than use "strace uuidgen -t" after reboot. You have to see that the util connects to the uuidd socket.

Not a bug from my point of view.
Comment 4 Karel Zak 2017-07-14 04:28:43 EDT
Note that ideal solution would be to use "enable uuidd.socket" in the spec file rather than "enable uuidd.service", but it's not so important.

Note You need to log in before you can comment on or make changes to this bug.