Bug 1470546 - [Regression] Error while generating Chargeback reports
[Regression] Error while generating Chargeback reports
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting (Show other bugs)
5.8.0
Unspecified Unspecified
high Severity high
: GA
: 5.9.0
Assigned To: Libor Pichler
Nandini Chandra
report:chargeback
: Regression, TestOnly, ZStream
: 1470545 (view as bug list)
Depends On:
Blocks: 1472837
  Show dependency treegraph
 
Reported: 2017-07-13 03:31 EDT by Nandini Chandra
Modified: 2018-03-06 10:00 EST (History)
6 users (show)

See Also:
Fixed In Version: 5.9.0.1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1472837 (view as bug list)
Environment:
Last Closed: 2018-03-06 10:00:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core


Attachments (Terms of Use)

  None (edit)
Description Nandini Chandra 2017-07-13 03:31:41 EDT
Description of problem:
-----------------------
Attempt to generate a Chargeback report results in this error.

ERROR -- : [TypeError]: no implicit conversion of nil into String  Method:[rescue in _async_generate_table]


Snippet from evm.log:

[----] I, [2017-07-13T03:14:15.537663 #2992:95f13c]  INFO -- : MIQ(MiqTask#update_status) Task: [10] [Active] [Ok] [Generating report]

[----] I, [2017-07-13T03:14:15.599505 #2992:95f13c]  INFO -- : MIQ(ChargebackVm.build_results_for_report_chargeback) Calculating chargeback costs...

[----] I, [2017-07-13T03:14:16.274985 #2992:95f13c]  INFO -- : MIQ(Chargeback::ConsumptionHistory.for_report) Found 7 records for time range [2017-07-13 00:00:00 UTC, 2017-07-13 23:59:59 UTC]

[----] I, [2017-07-13T03:14:16.314980 #2992:95f13c]  INFO -- : MIQ(ChargebackVm.build_results_for_report_chargeback) Calculating chargeback costs...Complete

[----] I, [2017-07-13T03:14:16.318074 #2992:95f13c]  INFO -- : MIQ(MiqReport#build_create_results) Creating report results with hash: [{:name=>"cb-owner", :userid=>"admin", :report_source=>"Requested by user", :db=>"ChargebackVm", :last_run_on=>2017-07-13 07:14:16 UTC, :last_accessed_on=>2017-07-13 07:14:16 UTC, :miq_report_id=>166, :miq_group_id=>nil}]

[----] E, [2017-07-13T03:14:16.377120 #2992:95f13c] ERROR -- : [TypeError]: no implicit conversion of nil into String  Method:[rescue in _async_generate_table]

[----] E, [2017-07-13T03:14:16.377399 #2992:95f13c] ERROR -- : /opt/rh/cfme-gemset/gems/activesupport-.0.3/lib/active_support/number_helper/number_to_currency_converter.rb:18:in `gsub'/opt/rh/cfme-gemset/gems/activesupport-5.0.3/lib/active_support/number_helper/number_to_currency_converter.rb:18:in `convert'/opt/rh/cfme-gemset/gems/activesupport-.0.3/lib/active_support/number_helper/number_converter.rb:132:in `execute'
/opt/rh/cfme-gemset/gems/activesupport-5.0.3/lib/active_support/number_helper/number_converter.rb:118:in `convert'
/opt/rh/cfme-gemset/gems/activesupport-5.0.3/lib/active_support/number_helper.rb:101:in `number_to_currency'
/opt/rh/cfme-gemset/gems/actionview-5.0.3/lib/action_view/helpers/number_helper.rb:403:in `public_send'
/opt/rh/cfme-gemset/gems/actionview-5.0.3/lib/action_view/helpers/number_helper.rb:403:in `block in delegate_number_helper_method'
/opt/rh/cfme-gemset/gems/actionview-5.0.3/lib/action_view/helpers/number_helper.rb:427:in `wrap_with_output_safety_handling'
/opt/rh/cfme-gemset/gems/actionview-5.0.3/lib/action_view/helpers/number_helper.rb:402:in `delegate_number_helper_method'
/opt/rh/cfme-gemset/gems/actionview-5.0.3/lib/action_view/helpers/number_helper.rb:121:in `number_to_currency'
/var/www/miq/vmdb/app/models/miq_report/formatting.rb:116:in `format_currency_with_delimiter'
/var/www/miq/vmdb/app/models/miq_report/formatting.rb:91:in `apply_format_function'
/var/www/miq/vmdb/app/models/miq_report/formatting.rb:76:in `format'
/var/www/miq/vmdb/app/models/miq_report/generator/html.rb:149:in `block (2 levels) in build_group_html_rows'
/var/www/miq/vmdb/app/models/miq_report/generator/html.rb:145:in `each'
/var/www/miq/vmdb/app/models/miq_report/generator/html.rb:145:in `each_with_index'
/var/www/miq/vmdb/app/models/miq_report/generator/html.rb:145:in `block in build_group_html_rows'
/var/www/miq/vmdb/app/models/miq_report/generator/html.rb:140:in `each'
/var/www/miq/vmdb/app/models/miq_report/generator/html.rb:140:in `build_group_html_rows'
/var/www/miq/vmdb/app/models/miq_report/generator/html.rb:58:in `build_html_rows'
/var/www/miq/vmdb/app/models/miq_report/generator.rb:351:in `build_create_results'
/var/www/miq/vmdb/app/models/miq_report/generator/async.rb:105:in `_async_generate_table'
/var/www/miq/vmdb/app/models/miq_queue.rb:347:in `block in deliver'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:91:in `block in timeout'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:33:in `block in catch'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:33:in `catch'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:33:in `catch'
/opt/rh/rh-ruby23/root/usr/share/ruby/timeout.rb:106:in `timeout'
/var/www/miq/vmdb/app/models/miq_queue.rb:343:in `deliver'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:107:in `deliver_queue_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:135:in `deliver_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:153:in `block in do_work'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:147:in `loop'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:147:in `do_work'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:341:in `block in do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:338:in `loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:338:in `do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:160:in `run'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:134:in `start'



Version-Release number of selected component (if applicable):
-------------------------------------------------------------
5.8.1.2


How reproducible:
----------------
Always


Steps to Reproduce:
-------------------
1.Manage a provider.Enable C&U collection for the provider.
2.Generate a Chargeback report for VMs.


Actual results:
---------------
Error while generating Chargeback reports


Expected results:
-----------------
Chargeback reports should be successfully generated.


Additional info:
----------------
Comment 2 Nandini Chandra 2017-07-13 03:37:29 EDT
Chargeback reports could be successfully generated in 5.8.1.0
Comment 3 Nandini Chandra 2017-07-13 12:30:09 EDT
*** Bug 1470545 has been marked as a duplicate of this bug. ***
Comment 4 Nandini Chandra 2017-07-17 04:35:43 EDT
Hi Libor,

This issue occurs intermittently.I'm running a few tests to understand what triggers this issue.
Comment 9 Nandini Chandra 2017-11-08 16:43:29 EST
Verified in 5.9.0.5

Note You need to log in before you can comment on or make changes to this bug.