Bug 1470554 - Adding fence agent through RESTApi fails with null pointer exception
Adding fence agent through RESTApi fails with null pointer exception
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core (Show other bugs)
4.2.0
Unspecified Unspecified
high Severity high (vote)
: ovirt-4.2.0
: 4.2.0
Assigned To: Eli Mesika
Petr Matyáš
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-13 03:53 EDT by Petr Matyáš
Modified: 2017-12-20 06:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:44:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
rule-engine: blocker+


Attachments (Terms of Use)
engine log (826.07 KB, text/plain)
2017-07-13 03:53 EDT, Petr Matyáš
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 79403 master MERGED core: fix NPE in fence agent port validation 2017-07-13 10:59 EDT

  None (edit)
Description Petr Matyáš 2017-07-13 03:53:25 EDT
Created attachment 1297445 [details]
engine log

Description of problem:
2017-07-12 18:12:15,820 - MainThread - agents - DEBUG - CREATE request content is --  url:/ovirt-engine/api/hosts/$host_id/fenceagents body:<agent>
    <address>$address</address>
    <concurrent>false</concurrent>
    <order>1</order>
    <password>$password</password>
    <type>ipmilan</type>
    <username>$username</username>
</agent>

Version-Release number of selected component (if applicable):
ovirt-engine-4.2.0-0.0.master.20170711205308.git8e7af78.el7.centos.noarch

How reproducible:
always

Steps to Reproduce:
1. send request from description
2. 
3.

Actual results:
	Status: 500
	Reason: Internal Server Error
	Detail: [General command validation failure.]

Expected results:
added fence agent

Additional info:
Comment 1 Red Hat Bugzilla Rules Engine 2017-07-13 08:41:00 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 2 Petr Matyáš 2017-07-21 06:20:55 EDT
Verified on ovirt-engine-4.2.0-0.0.master.20170719131008.gitde4718b.el7.centos.noarch
Comment 3 Sandro Bonazzola 2017-12-20 06:44:28 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.