Bug 1470560 - Command-line-tools page does not show copy button in iPad Pro & iPhone Safari
Command-line-tools page does not show copy button in iPad Pro & iPhone Safari
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Samuel Padgett
XiaochuanWang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-13 04:18 EDT by xipang
Modified: 2017-09-11 08:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-11 08:45:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xipang 2017-07-13 04:18:33 EDT
Description of problem:
Command-line-tools page does not show copy button in iPad Pro & iPhone Safari

Version-Release number of selected component (if applicable):
oc v3.6.140
kubernetes v1.6.1+5115d708d7
features: Basic-Auth

How reproducible:
Always

Steps to Reproduce:
1.login 
2.click drop-down menu at top right,click Command Line Tools 
3.Check login info clipboard

Actual results:
3.no show copy button at end of clipboard

Expected results:
3.Should have copy button for coping the login info directly.

Additional info:
Comment 1 Jessica Forrester 2017-07-13 07:12:59 EDT
I believe this is intentional because we cant support the copy to clipboard feature on iOS. Sam?
Comment 2 Samuel Padgett 2017-07-13 08:31:40 EDT
At one point, it didn't work on iOS, so we disabled it on purpose. I just tested in iOS Simulator, and it worked for me when I turned it back on. I believe we can fix this.
Comment 4 openshift-github-bot 2017-07-13 11:53:28 EDT
Commit pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/9e326a7e0991d4c66ee7a70c8e90d2ce89cbca5b
Bug 1470560 - Enable copy-to-clipboard for iOS
Comment 5 xipang 2017-07-17 03:04:43 EDT
Version:
openshift v3.6.151
kubernetes v1.6.1+5115d708d7

verified results:
show copy button at end of clipboard

QE is checking Modified bugs if they're verifiable. Because this bug is fixed, moving to Verified. If having other concerns, pls tell me, thx

Note You need to log in before you can comment on or make changes to this bug.